Solved

Exchange2010 witness server/folder stops automatic

Posted on 2014-01-25
25
358 Views
Last Modified: 2014-05-01
I have 2 exchange servers with all the roles installed.
and DAG configured. But evry 2-3 weeks witness I have to delete the witness folder and recreate otherwise if I restart any of these servers database will get dismounted.

But if delete the folder and recreate the folder and update from DAG properties it works fine.


Did anyone face the same issue before?
0
Comment
Question by:-MAS
  • 12
  • 11
  • +1
25 Comments
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 39810001
Have you tried putting the witness server on another machine? Do you get the same results?
What service pack are you running for exchange 2010? It would be recommended that you are running the last one so avoid any bugs.

You can verify the SP and Roll up at the below link.
Service Pack Roll Up

Will.
0
 
LVL 24

Author Comment

by:-MAS
ID: 39810052
I tried another witness but it is the same result
I am running exchange SP2
0
 
LVL 18

Accepted Solution

by:
suriyaehnop earned 250 total points
ID: 39811051
0
 
LVL 24

Author Comment

by:-MAS
ID: 39811146
It is working for few days and stops.
FM
Now I have a doubt that my FSMO holder is having performance issue as now internal emails taking more than 30seconds to deliver even test email. before it was less than 5 seconds.

It could be a reason?
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39811157
Can you explain where your witness share is? I hope it's not on the dag.
Exchange Trusted Subsystem is the security group you need to be concerned about.
0
 
LVL 24

Author Comment

by:-MAS
ID: 39811162
I configured in my DHCP server not in exchange server.
And Exchange Trusted Subsystem is a member of Local admin group
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39811173
Can you please check your Failover Cluster manager on the DAG. What is the state of the Witness resource during that time. Can you bring it online manually if its offline.
0
 
LVL 24

Author Comment

by:-MAS
ID: 39811989
I tried restarting one server and saw node is online is cluster manager but outlook is showing "Trying to connect..." or "Disconnected"


Now I can see the attached error but I can ping each other
screenshot.docx
0
 
LVL 4

Assisted Solution

by:pcmghouse
pcmghouse earned 250 total points
ID: 39814171
check your witness share using this command.
cluster dag.domain.com res

And second thing:
your client connects to cas server. how are you doing load balancing for the cas servers as they are on the same servers as mailbox role. you cannot use nlb. hardware load balancer will solve your situation efficiently.
One cas server restarts and your outlook disconnects and tries to connect to the second cas server. If you have a hw load balancer that will be more than quick.
And third:
Can you please run in exchange mgmt shell: get-clientaccessarray|fl
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39814199
0
 
LVL 24

Author Comment

by:-MAS
ID: 39814277
Resource             Group                Node            Status
-------------------- -------------------- --------------- ------
Cluster Name         Cluster Group        EXCH2010-1      Online
File Share Witness (\\win-2008.domain.com\DAG.nasser.com) Cluster Group
EXCH2010-1      Online
IPv4 DHCP Address 1 (Cluster Group) Cluster Group        EXCH-1      Online
IPv4 DHCP Address 2 (Cluster Group) Cluster Group        EXCH-1      Failed

Thsi is teh result of the first command
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39814280
Can you fix the IPs of the DAG instead of taking them from DHCP. make sure those IPs are excluded from DHCP distribution.
0
Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 
LVL 24

Author Comment

by:-MAS
ID: 39814430
It is already excluded from DHCP if I am not mistaken
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39814483
then fix the static ips for the dag.
0
 
LVL 24

Author Comment

by:-MAS
ID: 39814718
It is already assigned before
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39814752
IPv4 DHCP Address 2 (Cluster Group) Cluster Group        EXCH-1      Failed

Can you explain what this network is. The naming is not clear.
0
 
LVL 24

Author Comment

by:-MAS
ID: 39814757
EXCH-1  is the name of the server
This is our internal network not replication network
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39814782
I understand that.
Your IP(s) should be online on EXCH2010-1 as that is holding the other two resources.
Do you have assigned two V-IPs to the DAG.
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39814796
can you give the output for this:
get-databaseavailabilitygroup|fl *ip*

Also check if dag is getting IP from DHCP. I suggest you set it to static. Go to DAG/Properties/Ip Addresses.
0
 
LVL 24

Author Comment

by:-MAS
ID: 39814859
Result of command get-databaseavailabilitygroup|fl *ip*

DatabaseAvailabilityGroupIpv4Addresses : {10.0.0.27}
DatabaseAvailabilityGroupIpAddresses   : {10.0.0.27}

I still didn't understand how NODE IP is related to DAG IP?
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39814910
I still didn't understand how NODE IP is related to DAG IP?  Can you explain in detail.


node1 - 2 ips (lan, heartbeat).
node2 - 2 ips (lan, heartbeat).

dag - 1 virtual ip (note that this ip is not used for client connectivity purpose).

I hope all of the above are different.

Now can you check what is the IP assigned to the failed resource. From my point of view, you should see only three resources (cluster name, cluster ip [dag ip] and witness). Looks like the failed resource is not used.
0
 
LVL 24

Author Comment

by:-MAS
ID: 39817007
Now emails receiving after 5-6 minutes. Before it was less than 15 seconds.
But if switch databases to EXCH-1 emails flowing fast but when I switch DBs to EXCH-2 all the emails are very slow.
Any idea ?
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39817147
Can you show the cluster dagname res output now.

And second thing:
your client connects to cas server. how are you doing load balancing for the cas servers as they are on the same servers as mailbox role. you cannot use nlb. hardware load balancer will solve your situation efficiently.
One cas server restarts and your outlook disconnects and tries to connect to the second cas server. If you have a hw load balancer that will be more than quick.
And third:
Can you please run in exchange mgmt shell: get-clientaccessarray|fl
0
 
LVL 24

Author Comment

by:-MAS
ID: 39827301
Attached results
results.txt
0
 
LVL 24

Author Closing Comment

by:-MAS
ID: 40034822
I ended up installing one more mailbox server and added to and now its stable.

Thanks to all
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

947 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now