Solved

document mode 7

Posted on 2014-01-25
6
372 Views
Last Modified: 2014-01-28
Dear all,
One of our client's web site work perfectly on ie11  if customer browse the web site in document mode 7...
Using html code How can force ie 11 to browse the web site on 7 ?

thanks,
0
Comment
Question by:ethar1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 39810417
You will need to add this in the head of the document:
<meta http-equiv="x-ua-compatible" content="IE=7">

That should direct the browser to use compatibility mode for ie7.

More detail about how is works can be found on the Microsoft developer site:

http://msdn.microsoft.com/en-us/library/jj676915%28v=vs.85%29.aspx

Cd&
0
 

Author Comment

by:ethar1
ID: 39810708
I already use each one of those:
<metax http-equiv="x-ua-compatible" content="IE=EmulateIE5" >
<metax http-equiv="x-ua-compatible" content="IE=5">
<meta http-equiv="x-ua-compatible" content="IE=7">

<meta http-equiv="x-ua-compatible" content="IE=edge" > 

but nothing effected.
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 39813115
Then either there is something else wrong with the page (like no valid doctype) or it is an as yet unreported bug in IE11.

What doctype are you using?

BTW, anything that relies on IE7 compatibility needs to be re-written because IE10 was the last to support it with native compatibility mode, and IE 11 may be the last to recognize IE7 ever existed.  At some point obsolete pieces have to be replaced or they will fail.

Cd&
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:ethar1
ID: 39814188
<!DOCTYPE html>
btw, when I open Developer Tools F12 , and change the document mode to 7, it work perfectly.
0
 
LVL 44

Accepted Solution

by:
Rainer Jeschor earned 500 total points
ID: 39814240
Hi,
IE is very picky if the meta tag is not one of the very first elements in the html head, therefore can you ensure that this meta tag is on top (with nothing else than the head tag before)?
Which web server are you using?
If its IIS then you can also configure IIS to send additional header information, setting the http-equiv directly there:
http://weblogs.asp.net/joelvarty/archive/2009/03/23/force-ie7-compatibility-mode-in-ie8-with-iis-settings.aspx

HTH
Rainer
0
 

Author Comment

by:ethar1
ID: 39815092
work , thanks
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article discusses four methods for overlaying images in a container on a web page
When crafting your “Why Us” page, there are a plethora of pitfalls to avoid. Follow these five tips, and you’ll be well on your way to creating an effective page.
In this tutorial viewers will learn how to embed an audio file in a webpage using HTML5. Ensure your DOCTYPE declaration is set to HTML5: : The declaration should display (CODE) HTML5 is supported by the most recent versions of all major browsers…
The viewer will learn the basics of jQuery including how to code hide show and toggles. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question