Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Exchange 2013 CAS server certificate problem

Posted on 2014-01-26
5
Medium Priority
?
443 Views
Last Modified: 2014-02-19
I have 4 exchange 2013 servers 2 Mailbox and 2 CAS running in win 2008 r2. When I check the certificates using power shell in the CAS02 it is shown the certificate of mailbox01.

But in ECP showing correctly. Also when I tried to import the third part certificate in cas02 I am getting an error certificate with this thump is already there.
Cas02-Certi.jpg
Certilist.jpg
0
Comment
Question by:jobby1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 4

Assisted Solution

by:pcmghouse
pcmghouse earned 750 total points
ID: 39811134
Please run command "get-exchangecertificate -server yourservername".
Have you assigned any services to the certificate?
0
 
LVL 27

Assisted Solution

by:MAS
MAS earned 750 total points
ID: 39811154
As suggested above check the certificates in CAS02
And enable services using the command below
Enable-ExchangeCertificate -Thumbprint 5113ae0233a72fccb75b1d0198628675333d010e -Services POP,IIS,SMTP. etc

http://technet.microsoft.com/en-us/library/aa997231(v=exchg.150).aspx
0
 

Author Comment

by:jobby1
ID: 39817446
Do I need to remove default certificate.

Do I need to remove the services for the default certificates.
0
 
LVL 4

Assisted Solution

by:pcmghouse
pcmghouse earned 750 total points
ID: 39817501
Were you able to import the certificate.
Do not remove the default ones. SMTP will work fine with the self-signed ones.

You can assign IIS services. But you have to make sure that your third party certificate is a SAN or wild card. And it is valid.

Provide output for get-exchangecertificate -server yourcasservername.

This IIS cert will be used in OWA, Outlook connectivity.
0
 
LVL 27

Accepted Solution

by:
MAS earned 750 total points
ID: 39817555
As suggested by pcmghouse let the SMTP enabled on self signed certificate and enable IIS on the new one
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
A walk-through example of how to obtain and apply new DID phone numbers to your cloud PBX enabled users that are configured in Office 365. Whether you have 1, 10 or 100+ users in your tenant, it's quite easy to get them phone-enabled and making/rece…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question