Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 159
  • Last Modified:

Asp.net config error. How do I remove parent's default role provider in child config

I'm getting a configuration error in my Asp.net app. The parent config for the site has got the following section (shown first below):


My application is now showing the error shown 2nd below. How do I specify in my child config file to ignore this setting?

Thanks!


1) Parent Config:
<roleManager enabled="true" cacheRolesInCookie="false" cookieName=".ASPXROLES" cookieTimeout="30" cookieRequireSSL="false" cookiePath="/" cookieSlidingExpiration="true" cookieProtection="All" defaultProvider="FSSRoleProvider" createPersistentCookie="false" maxCachedResults="25">
  <providers>
    <clear />
    <add name="FSSRoleProvider" type="SXA.PTL.Framework.Role.FSSRoleProvider" />
  </providers>
</roleManager>


2) My error:

Server Error in '/PatientOutreach' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Default Role Provider could not be found.

Source Error:


Line 1:  <?xml version="1.0" encoding="utf-8" ?>
Line 2:  <roleManager enabled="true" cacheRolesInCookie="false" cookieName=".ASPXROLES" cookieTimeout="30" cookieRequireSSL="false" cookiePath="/" cookieSlidingExpiration="true" cookieProtection="All" defaultProvider="FSSRoleProvider" createPersistentCookie="false" maxCachedResults="25">
Line 3:    <providers>
Line 4:      <clear />

Source File: C:\PPUI6.1SU5\PPUI\RoleManager.config    Line: 2
0
_Wade_
Asked:
_Wade_
1 Solution
 
Easwaran ParamasivamCommented:
In your child, you want the RoleManager but not the provider? I don't think so that could be right.

However either rolemanager or provide expects below element which is not available. Kindly check it out.

defaultProvider="YourProvider"

Open in new window

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now