Could not switch to AHCI mode on my eMachine.

I have an eMachine ET-1352-53. I upgraded the HD to Samsung SSD 840 EVO 250GB. Everything is working fine and it runs noticeably faster, but it is making only about 40% of the targeted benchmark scores in the SSD's own Samsung Magician software!

In that same software, when I go to the OS Optimization menu, it stated the following: "AHCI is disabled for one or more connected SSDs. System must boot in AHCI mode for best performance."

I didn't find anything in my BIOS to change it, so I googled and saw an article stating: "In your BIOS select "Integrated Peripherals" and OnChip PATA/SATA Devices. Now change SATA Mode to AHCI from IDE."
http://forums.guru3d.com/showthread.php?t=313676

However, when I tried to go to eMachine's BIOS, under Integrated Peripherals (and anywhere else I searched) I could not find any place where there is any option to switch from SATA to AHCI.

Am I missing something? Or is my desktop incompatible with AHCI mode? I certainly hope it's not the latter!

Thanks in advance!
sew
LVL 14
sungenwangAsked:
Who is Participating?
 
☠ MASQ ☠Connect With a Mentor Commented:
Darr247's plan is sound but you can't deliberately switch AHCI on & off, the BIOS does that automatically depending on what devices it detects at POST.

If the SSD is being handled as an IDE/PATA device then if that's the only storage device detected at boot then the system should switch off AHCI & that should allow you to install the drivers as Darr247 has suggested.

I still think you are getting the best performance you're able out of the system but I (and I'm sure you too) would be delighted to be proved wrong.
0
 
DavidConnect With a Mentor PresidentCommented:
Buy a $19.95 SATA controller that supports AHCI if your motherboard doesn't support it.
0
 
☠ MASQ ☠Commented:
There isn't a PATA/SATA BIOS option on this SATA II motherboard, it should autodetect that a SATA drive is attached and switch controller accordingly.  Your SSD is badged as SATA 3 but backwards compatible with both earlier standards.  Wonder if Samsung Magician is expecting you to be achieving a 6Gb/s transfer rate.  Otherwise this is some kind of hardware incompatibility.
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
Darr247Commented:
Be sure you install the AHCI drivers first, or you'll get a BSOD with a Stop: 0x0000007B error.

Even with the AHCI drivers installed, you might get the 7B stop error, but booting to Safe mode once should fix that (if not, there's a knowledgebase article that addresses it).
0
 
sungenwangAuthor Commented:
I ran Darr247's suggested knowledgebase article (MicrosoftFixit50470.msi) and my BIOS still does not show any option for me to select AHCI.

Where do I go from here??
1. If I buy a SATA controller dledhe suggested, will that fix the problem? Can you include an newegg/amazon link of the type of controller I need?
2. Or is it a dead deal as MASQUERAID seems to have suggested?

Thanks again!
0
 
Darr247Connect With a Mentor Commented:
The knowledgebase article is to fix windows if the AHCI drivers are installed already but have never been enabled.  

You have to switch the drive controller in Integrated Peripherals back to IDE (instead of AHCI) in the BIOS, install the AHCI drivers, then run that fixit and reboot... *then* boot into BIOS, change the drive controller in Integrated Peripherals from IDE (not SATA) mode back to AHCI, and boot into Windows again.
0
 
☠ MASQ ☠Commented:
Are we not going in circles here?  There is no option for an AHCI/PATA mode in the BIOS - the board autodetects the drives connected.  If this is going to work you need to disconnect any drives that are being handled as SATA (including optical) and trust that the SSD is actually being treated as IDE/PATA by the BIOS.  That's the only way you'll be the system out of AHCI mode.  This is the "Catch22" I was describing earlier.
0
 
sungenwangAuthor Commented:
Darr247,
There is no place in my eMacine BIOS setting that I can switch between IDE or AHCI. I've looked throught all the options over and over...

MASQUERAID,
I'm not sure what you are suggesting... Do you suggest that I disconnect all the drives first (DVD & HD) and boot up and see what happens?? Or is it a moot point and that I should just live with the 40% SSD speed due to no AHCI support on my PC?

Thanks!
0
 
sungenwangAuthor Commented:
Thanks to all... I am indeed satisfied with the SSD speed until I saw the benchmark... was just a bit greedy to squeeze out all possible performances :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.