Solved

QOS using DSCP

Posted on 2014-01-26
11
450 Views
Last Modified: 2014-06-23
Hi Experts

I wanted to implement QOS for our internal voip traffic. The setup we have is  

AudioCode MP124 --> cisco SG300 ---> cisco catalyst 2960 ----> SIP Telephony Server.

we do not have any vlan's configured. The question I have is will DSCP works in that environment and if it does then will the switches has to be on layer 3 mode ?

Thanks in advance

Saqib
0
Comment
Question by:nocinfospan
  • 6
  • 3
  • 2
11 Comments
 
LVL 6

Accepted Solution

by:
Jordan Medlen earned 500 total points
ID: 39811859
The switches do not need to be in layer 3 mode, however your voice traffic can potentially get walked all over by other traffic on the network.

You can implement a QoS policy on your switches to help prioritize voice traffic over all other traffic to help avoid poor voice quality when competing with other traffic for bandwidth.

Something like the following would work to prioritize traffic using SIP and RTP on a Cisco switch...

mls qos
!
access-list 102 remark Classification of VOIP Traffic both Control and Voice
access-list 102 permit udp any any eq 5060
access-list 102 permit tcp any any eq 5060
access-list 102 permit udp any any range 10000 20000
!
class-map match-any VOIP-CLASS
  match access-group 102
!
policy-map VOIP-MAP
 class VOIP-CLASS
   set dscp ef
!

Open in new window


Then applying to an access port, meaning a switch port connecting to an end station, such as a phone or workstation, etc...

interface GigabitEthernet0/1
 switchport mode access
 priority-queue out 
 mls qos trust dscp
 spanning-tree portfast
 spanning-tree bpduguard enable
 service-policy input VOIP-MAP

Open in new window


On your trunk/uplink ports to other switches and routers, you'd configure like...

interface GigabitEthernet0/48
 switchport mode trunk
 priority-queue out 
 mls qos trust dscp
 spanning-tree bpduguard disable

Open in new window


Please know these are just examples and your implementation may require differing configurations.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39813194
Are you suffering congestion on your LAN? Until there is congestion, you are simply just marking the traffic. If there is congestion on your LAN, I would remedy that before going the QOS route.
0
 
LVL 1

Author Comment

by:nocinfospan
ID: 39818644
@Jordan

thanks for the reply. Right now i can mark the traffic from the audio code gateways but the IP telephony server we have is not able to mark the traffic for DSCP ( I confirm this by using wireshark trace).

so to give the SIP and RTP traffic priority should i use the same commands/logic that you mentioned in your first post ? is there any thing else that i need to look into ?
0
 
LVL 6

Expert Comment

by:Jordan Medlen
ID: 39818753
Yes, you would use the commands that I posted. This would classify and mark the traffic so that regardless of what the telephony server or devices set, you have consistent marking of the traffic for higher prioritization.
0
 
LVL 1

Author Comment

by:nocinfospan
ID: 39818955
@jordan

Thanks jordan ... How can i debug the packets that are being matched on the switch and forward to the priority queue ?
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 1

Author Comment

by:nocinfospan
ID: 39819804
and one more question how would i add access-list for all other traffic in the acl list ?
0
 
LVL 6

Expert Comment

by:Jordan Medlen
ID: 39820765
Not sure what you mean. There would be no reason to add any other traffic to the ACL. Any and all traffic added to the ACL would then receive the same priority markings.
0
 
LVL 1

Author Comment

by:nocinfospan
ID: 39821561
So when i am applying service policy to the interface it only allows sip and rtp traffic and all other traffic like http etc is denied.

Also correct me if i am wrong in this. If i apply

policy-map VOIP-MAP
 class VOIP-CLASS
   set dscp ef

that's means all the packets with sip and rtp assigned the value with expedite forwarding (DSCP value 46) , means overwrite the DSCP value in the packet from 0 to 46 ?
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39821590
That looks correct. Yes ,any traffic mathing the VOIP-CLASS acl will be remarked EF.
All other traffic will not be affected by the service policy.
0
 
LVL 1

Author Comment

by:nocinfospan
ID: 39822996
Hi i have these commands in my running configuration because before i applied the auto qos on the switch.
mls qos srr-queue input threshold 1 80 90
mls qos srr-queue input priority-queue 2 bandwidth 30
mls qos srr-queue input cos-map queue 1 threshold 2 3
mls qos srr-queue input cos-map queue 1 threshold 3 6 7
mls qos srr-queue input cos-map queue 2 threshold 1 4
mls qos srr-queue input dscp-map queue 1 threshold 2 24
mls qos srr-queue input dscp-map queue 1 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue input dscp-map queue 1 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue input dscp-map queue 2 threshold 3 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
no mls qos rewrite ip dscp
 

will that be any effect ?
0
 
LVL 1

Author Comment

by:nocinfospan
ID: 39823177
Also on the cisco SG300 switch on the policy binding page it says
"
Policy Binding
A port can be bound with either a policy or an ACL, but not both. The default action is to discard (Deny Any) all the packets that do not meet the rules in a policy.
You can override the default action of a policy to forward those packets by configuring Permit Any on the desired ports."
0

Featured Post

Save on storage to protect fatherhood memories

You're the dad who has everything. This Father's Day, make sure your family memories are protected. My Passport Ultra has automatic backup and password protection to keep your cherished photos and videos safe. With up to 3TB, you have plenty of room to hold the adventures ahead.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco Mutual Redistribution BGP OSPF Loop Prevention 5 218
EIGRP  router failure 14 40
Porting numbers 3 62
Is there a monitoring tool to see network usage per user? 5 53
SSL is a very common protocol used these days when browsing the web.  The purpose is to provide security to communication, but how does it do it?  There are several pieces at work that have to be setup before SSL will even work and it requires both …
Outsource Your Fax Infrastructure to the Cloud (And come out looking like an IT Hero!) Relative to the many demands on today’s IT teams, spending capital, time and resources to maintain physical fax servers and infrastructure is not a high priority.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now