Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 930
  • Last Modified:

How to setup Active sync for mobile devices on Exchange 2010 running on Windows Small Business Server 2011

I have setup dozens of Mobile Active sync's on Windows 2003 SBS servers, to perfectly sync the exchange Outlook profiles with Android and Iphone devices for years. I am new to the SBS 2011 and Exchange 2010, and am wondering if there is a nice guide out there to setup the same type of active Sync to Android and Iphone. I don't need a guide on how to do it on the devices, I need a guide to get it up and running on the SBS 2011 Server with Exchange 2010 so it's accessible to the mobile devices.

I am also noticing that the OWA and internal website is not running either. I am generally used to doing a http://name of server/exchange in IE and seeing the internal server website that allows you to get to OWA. When I do It on this new server I get an error that looks like IIS is not running. ERROR BELOW:

Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
Any help would be appreciated. Thanks.
0
ZionTech1
Asked:
ZionTech1
3 Solutions
 
Olaf De CeusterCommented:
I will get in trouble from other experts but there is a tool to see if the server is setup properly.
Try the SBS BPA . Once installed it is an invaluable tool.
http://support.microsoft.com/kb/2673284
Hope that helps,
Olaf
0
 
Alan HardistyCommented:
General rule of thumb on SBS 2011 is install Exchange Service Packs / Rollups as they don't come down via Windows Update, install an SSL certificate and it should work out of the box with no messing about!

Latest Exchange 2010 Service Pack is SP3 and then Rollup 4 for SP3 is the latest update available.

Alan
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
First of all, if you want to access Outlook Web App locally the URL has changed.

It's now https://servername/owa

(it is normal to get the error you see if you try to go to /exchange)

Then, ActiveSync on SBS 2011 is configured by default, as long as you have run the "Set up your Internet address" wizard.  It also is best to use a third-party SSL certificate which should be installed using the "Add a trusted certificate" wizard.

You can test to see if ActiveSync is working by using this site:
https://testconnectivity.microsoft.com/

Jeff
TechSoEasy
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now