Solved

SharePoint - Warm-up with PowerShell vs. App Initialization

Posted on 2014-01-27
5
1,730 Views
Last Modified: 2014-01-28
I have a SharePoint 2013 farm with two app servers and three WFE's. These are running on W2012 Server. I have implemented App Initialization thinking that this would replace what I have always done, used a PowerShell script to warm up the site. I do not see any improvement in performance really however, so either I have App Initialization implemented incorrectly or it does not warm up the farm as I thought it would. Any advice or ideas would be appreciated.

Thanks
0
Comment
Question by:Walter Curtis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 44

Accepted Solution

by:
Rainer Jeschor earned 500 total points
ID: 39812507
Hi,
how did you configure this?
A good step-by-step can be found here:
http://thesharepointfarm.com/2012/06/sharepoint-warm-up-scripts-a-thing-of-the-past/

HTH
Rainer
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39812672
In my experience the App Init. process only works on anonymous sites.  

This is the latest one I've been using for non-anon sites.
0
 
LVL 18

Author Comment

by:Walter Curtis
ID: 39812714
Thanks for the good information. I am going to review and run with them. Here is what I based my configuration on:

http://www.iis.net/learn/get-started/whats-new-in-iis-8/iis-80-application-initialization


I will update results as soon as I can.

Danke
0
 
LVL 18

Author Comment

by:Walter Curtis
ID: 39815170
Update - following your link Rainer, I reconfigured my farm and performance is greatly improved, very good in fact. Achilles, thanks for the information, but I am able to avoid a warm up script now.
0
 
LVL 18

Author Closing Comment

by:Walter Curtis
ID: 39815183
I had configured the Start Mode via the applicationhost.config file for all servers in the farm and all web apps. I must have done it wrong because using IIS Manager (GUI), all web apps showed as on-demand still. Thanks for the article from Rainer the got me to check in the GUI and then correctly set the setting. Performance is as it should be now. vielen dank
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The following article is comprised of the pearls we have garnered deploying virtualization solutions since Virtual Server 2005 and subsequent 2008 RTM+ Hyper-V in standalone and clustered environments.
Understanding the various editions available is vital when you decide to purchase Windows Server 2012. You need to have a basic understanding of the features and limitations in each edition in order to make a well-informed decision that best suits y…
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question