afxres.h -- error RC1015

I am compiling code and getting the following error:

Error      1      error RC1015: cannot open include file 'afxres.h'.      C:\Program Files (x86)\EldoS\Callback File System\Samples\CPP\VDisk\VDisk.rc      10      1      VDisk

Please help---any ideas?
nymaestroAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
jkrConnect With a Mentor Commented:
VC++ Express does not come with MFC, and 'afxres.h' belongs to the MFC library. Even worse, it's part of MFC's resources (thus the 'res'), and all Express versions come without a resource compiler and therefore no support for any resources embedded into projects. Try removing all resource entries - yet that will not guarantee that you will get the whole thing to run, esprecially when the resources contain UI elements.
0
 
jkrCommented:
Ooops, one idea to remedy the situation - get the resource compiler from the Platform SDK (pardon, nowadays the "Windows SDK"): http://www.microsoft.com/click/services/Redirect2.ashx?CR_EAC=300135395
This will still mean that you have to compile the resources manually, but hey...
0
 
sarabandeCommented:
if the rc file includes "afxres.h" the sample project could be a mfc project which cannot be built without the mfc include folders and the mfc libraries (both import libraries and dll's).

the sdk will not include those files.

look at the ...\Samples\CPP\VDisk\VDisk.vxcproj with notepad (or visual studio text editor by using the 'edit with ...'). if the file does not exist, check if there is another *.vxcproj or *.vcproj file in the VDisk folder. the xml tree in this file should contain info which version of VC compiler is required and whether MFC is required.

I looked at EldDos faq and the failing afxres.h include seemed to be a known issue. some people replaced the afxres.h by winres.h and it compiled (with warnings you probably can ignore). I don't know whether the workaround could work for VDisk also, because the look-and-feel of the dialog presented at the web page is that of a mfc dialog what would mean you have to install at least the standard edition of the visual studio before you can build it.

Sara
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.