Solved

Multiple RDC connections to Windows 7 workstations with Cisco RV220W

Posted on 2014-01-27
13
407 Views
Last Modified: 2014-01-27
Hi experts,

I'm trying to configure a Cisco RV220W to allow multiple RDC connections to Windows 7 workstations from the Internet.

I have been able to set it up to successfully connect to one. However when I add a second entry in the access rules on the Cisco RV220W, I cannot connect to the second computer.

I have changed the standard RDC port and have a different port setup for each computer.

There are 2 rules in the Cisco RV220W, each one points to one IP address of the computers I'm trying to connect to. I setup the second identical to the first, with the exception of the IP address of the computer I'm trying to connect to.

If I remove the first, the second one works, if I remove the second, the first works, so it seems like it can only connect to one at a time.

Any thoughts or suggestions on how to allow multiple RDC connections from the outside?
0
Comment
Question by:ChiIT
  • 7
  • 6
13 Comments
 
LVL 5

Expert Comment

by:Jullez
ID: 39813377
Are you able to RDP internally with the ports you changed to each machine?
0
 
LVL 2

Author Comment

by:ChiIT
ID: 39813674
Hi, thanks for responding. Yes I can. If I only put one entry into the access rules as a time, I can actually connect to either based on the access rule I put in. (different IP addresses).

I've included screen shots of the Cisco config....

when I only have 1 inbound entry, I can connect. When I add 2, I can't connect to both, only the first one I entered..
accessrules1.jpg
accessrules2.jpg
0
 
LVL 5

Expert Comment

by:Jullez
ID: 39813694
What do you have configured in port forwarding section?
0
 
LVL 2

Author Comment

by:ChiIT
ID: 39813747
I don't have anything in there. Its empty. I found this article, and it sounded like access rules was the way to set this up.....though, now that I read this, sounds like it was for between 2 routers rather than to desktops......

http://sbkb.cisco.com/CiscoSB/GetArticle.aspx?docid=e2ba2b891ee24260bdd79e3b95498c55_Configuration_of_Remote_Desktop_Protocol_on_RV120W_and_RV220.xml&pid=2&converted=0
0
 
LVL 5

Expert Comment

by:Jullez
ID: 39813753
In port forwarding, set the correct IP address corresponding to the RDP port you have configured on the machines.
0
 
LVL 2

Author Comment

by:ChiIT
ID: 39813768
It needs to be a different port for each computer, correct?
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 5

Expert Comment

by:Jullez
ID: 39813780
Yes, from outside you will be connecting to x.y.z.w:3391 (port that you configured on the workstation), 2 port forwarding rules.
0
 
LVL 2

Author Comment

by:ChiIT
ID: 39813809
attached is what I entered....I had to create a custom service, which I put in a port range that includes both computers....

the same thing happens..when I only have one port forward in there, I can connect, when I put the second one in, I can only connect to the first one...

It doesn't matter if I put in the port for computer 1 or 2, I can connect to whichever one is in there when its only 1...

do I need to make a separate custom service for each port? there is the ability to put in a range in the config...
portforward1.jpg
portforward2.jpg
0
 
LVL 5

Accepted Solution

by:
Jullez earned 500 total points
ID: 39813819
You have to use a custom port - cant just use RDC for both.

Call them RDC3390 and RDC 3391 etc.

Firewall > Advanced Settings > Custom Settings. Add a new service specifying the name, protocol, and ports.

Firewall > Port Forwarding and add a port forwarding record. And set the following values.

 
Action: Always Allow

Service: <Your Newly Created Service>

Destination IP: <Your internal address>

Forward From Port: Same as incoming port

Forward To Port: <RDP port on machine>
0
 
LVL 2

Author Comment

by:ChiIT
ID: 39813846
I think that worked...testing.....
0
 
LVL 2

Author Comment

by:ChiIT
ID: 39813878
it works...thank you VERY much. I'm not sure I understand why the port range doesn't work under the custom service I created...but I just tested it all, custom service with only a single port works for both computers, a single custom service with a range does not...

Luckily I only have a few computers that need this. If I have 100 I can see it would get to be a bit of a chore entering all of the custom services...
0
 
LVL 2

Author Closing Comment

by:ChiIT
ID: 39813901
Excellent help, thank you very much
0
 
LVL 5

Expert Comment

by:Jullez
ID: 39813906
You are very welcome!
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now