?
Solved

Pygame Installer needs System Python. Please Help me do this correctly

Posted on 2014-01-27
10
Medium Priority
?
712 Views
Last Modified: 2014-03-12
Hi
I have IDLE python installed and working.

To install pygame, I have the Mac mpkg :

pygame-1.9.1release-python.org-32bit-py2.7-macosx10.3

If I open it, it says
1.9.1 can't be installed on this disk... requires System Python 2.7 to install.

Do I have the correct files? Where do I get the correct system python from?

How can I need an earlier Python if I have 3.3.3? What about backwards compatibly? Is this page correct to get 2.7 here ?
I have OS X Snow Leopard

Thanks
0
Comment
Question by:beavoid
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
10 Comments
 
LVL 35

Accepted Solution

by:
Dan Craciun earned 2000 total points
ID: 39813565
pygame is somewhat old and the latest official stable release, which is from 2009, only supports Python 2.

That being said, a significant part of the community did not make the switch to Python 3 yet. Troubles with backward compatibility.

There was a project to port pygame to Python 3, but it appears abandoned: http://www.pygame.org/wiki/python3porting?parent=index

You can get the latest Python 2 from here: http://www.python.org/download/releases/2.7.6/

Since the web page of pygame is rarely updated, you can get the latest releases (don't know if they are stable, and it's Windows only) from here: https://bitbucket.org/pygame/pygame/downloads

You'll see they have Python 3 versions also.

HTH,
Dan
0
 
LVL 35

Assisted Solution

by:Dan Craciun
Dan Craciun earned 2000 total points
ID: 39813592
If you're wondering if you should use Python 2 or 3, here's the official page for it: https://wiki.python.org/moin/Python2orPython3
0
 

Author Comment

by:beavoid
ID: 39813939
Is there any word of an expected date for py game 3's release
0
Enroll in August's Course of the Month

August's CompTIA IT Fundamentals course includes 19 hours of basic computer principle modules and prepares you for the certification exam. It's free for Premium Members, Team Accounts, and Qualified Experts!

 
LVL 35

Expert Comment

by:Dan Craciun
ID: 39814130
Nope. But you may ask on their IRC: irc.freenode.net 6667 #pygame
0
 

Author Comment

by:beavoid
ID: 39816862
Is that a link? What must I put in the URL bar?

Thanks
0
 
LVL 35

Expert Comment

by:Dan Craciun
ID: 39817097
You need an IRC client. If you use Firefox search for Chatzilla in add-ons: https://addons.mozilla.org/en-US/firefox/addon/chatzilla/
0
 

Author Comment

by:beavoid
ID: 39818018
I only have safari :(
0
 
LVL 35

Expert Comment

by:Dan Craciun
ID: 39818199
Here's a list of Mac IRC clients: http://www.irchelp.org/irchelp/clients/mac/
0
 

Author Comment

by:beavoid
ID: 39819608
The one I chose, Snak, has low attendance, and is not user friendly.

There doesn't seem to be a field to enter

 irc.freenode.net 6667 #pygame
0
 

Author Comment

by:beavoid
ID: 39819926
The one I chose, Snak
has pathetic attendance and isn't user friendly :/

I have a PC. Is IRC ready2go in IE ?

I am concerned that Python doesn't have all these UI / window capabilities readily at hand that Java always had. How else is data entered into a program?

TKinter is supposed to be the given window oriented interface?
But, there have been porting issue since 3.3.3 came along?

Just found this Tkinter 3.3 page here. Anybody know if it's okay? here
Thanks
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Installing Python 2.7.3 version on Windows operating system For installing Python first we need to download Python's latest version from URL" www.python.org " You can also get information on Python scripting language from the above mentioned we…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Learn the basics of if, else, and elif statements in Python 2.7. Use "if" statements to test a specified condition.: The structure of an if statement is as follows: (CODE) Use "else" statements to allow the execution of an alternative, if the …
Learn the basics of modules and packages in Python. Every Python file is a module, ending in the suffix: .py: Modules are a collection of functions and variables.: Packages are a collection of modules.: Module functions and variables are accessed us…
Suggested Courses
Course of the Month13 days, 16 hours left to enroll

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question