Solved

I am setting up a new Cisco 3750 and need guidance on creating port-channel/etherchannel

Posted on 2014-01-27
2
2,655 Views
Last Modified: 2014-02-03
Hello EE,
I have a new 3750 and want to create a Port Channel and add a few switch ports to it.
Can somebody guide me on how to do this?  I see one that has a (D) but looking at mine I have Po6(SU) with Te1/1/1(P) and Te3/1/2(P) that I want to create identically in my new switch?
0
Comment
Question by:bergquistcompany
2 Comments
 
LVL 45

Accepted Solution

by:
Craig Beck earned 500 total points
ID: 39813762
You should create the PortChannel interface first.  This is a virtual interface which will govern the physical interface configuration.

So, if you want a PortChannel which is configured to carry a single VLAN you'd do this...

interface Po2
 switchport
 switchport mode access
 switchport access vlan 10
!
interface range Te1/1/1 , Te3/1/2
 switchport
 switchport mode access
 switchport access vlan 10
 channel-group 2 mode active
!

Open in new window

This would put ports Te1/1/1 and Te3/1/2 in Po1 and allow VLAN10.

For a trunk you'd do something like this...

interface Po2
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,30,50
 switchport trunk native vlan 100
!
interface range Te1/1/1 , Te3/1/2
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,30,50
 switchport trunk native vlan 100
 channel-group 2 mode active
!

Open in new window


Note that the PortChannel interface number is the number you configure in the channel-group command in the physical interfaces.

When changing the configuration, adjust the PortChannel interface and the changes will filter down to the physical interfaces which form that PortChannel.

The channel-group command can use several modes.  These are:

active - enables LACP unconditionally
passive - enables LACP if an LACP device is detected
desirable - enables PAgP unconditionally
auto - enables PAgP if a PAgP device is detected
on - creates a static EtherChannel

You can use active/passive, or desirable/auto, active/active, auto/auto or on/on.

So, on one end of the link you might want to tell the switch to use PAgP no matter what.  That end would use channel-group 2 mode desirable.  The other end could use either auto or desirable, but not active, passive or on.

Make sense?
0
 

Author Closing Comment

by:bergquistcompany
ID: 39831328
great details
0

Featured Post

Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Destination host unreachable 12 69
Network Switches Keep Failing 8 69
Packet Tracer Router to Router 10 60
Shoretel Edge Gateway 5 44
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now