Solved

SQL 2008 - domain user can`t login , local SQL user can

Posted on 2014-01-28
9
868 Views
Last Modified: 2014-02-07
Hello,
I created a new login on my sql server for a domain user.
local sql user works with no problem
I checked the user and pwd in AD - all OK
user is enabled & i checked the effective permissions and the user has connect & select enabled.

Windows server 2008 R2 + SQL Server 2008

thanks in advance
0
Comment
Question by:FiremanFpG
  • 5
  • 3
9 Comments
 
LVL 69

Expert Comment

by:ScottPletcher
ID: 39815105
Verify that the AD user/group has access to the default db assigned in SQL Server for that user/group.  Login will fail if you can't get to the default db -- or the db specified in the connect string that overrides the default db.
0
 

Author Comment

by:FiremanFpG
ID: 39815165
I tried adding the account to the default database but same problem
I also changed the default database to the database that I need access to and verify the user I created has datareader rights - same error
I can login using management studio with the user but when i try to connect from excel I get an error - login failed for user
I tried with domain\user syntax and just the user - but same error on both
0
 
LVL 69

Expert Comment

by:ScottPletcher
ID: 39815372
Oh, from Excel.  Can you connect from SS Management Studio as that AD user?
0
 
LVL 11

Expert Comment

by:John_Vidmar
ID: 39815724
My interpretation, you've created a SQL Server instance on your workstation and you want someone on your domain to interact with that instance via Active-Directory.  Without seeing the error, and assuming you've created the login correctly in your instance; I suspect a firewall is preventing access to the port your instance is listening for requests.
0
NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

 

Author Comment

by:FiremanFpG
ID: 39815784
I can connect with the AD user with the management studio.
About the excel - if I use an SQL user I can connect with no problem
0
 
LVL 69

Expert Comment

by:ScottPletcher
ID: 39816508
Probably the Excel connection is set to "native SQL login" and not to "trusted login".  You need to change the connection setting to specify "trusted"/"domain" login in Excel when using an AD login.
0
 

Author Comment

by:FiremanFpG
ID: 39827366
how do i change it in excel ?
0
 

Accepted Solution

by:
FiremanFpG earned 0 total points
ID: 39827601
I Found the problem, i needed to add the users to the local SQL group on the server (Local Server 2008 group)
now it`s working
0
 

Author Closing Comment

by:FiremanFpG
ID: 39841367
that was the solution that solved it
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
I have a large data set and a SSIS package. How can I load this file in multi threading?
This video shows, step by step, how to configure Oracle Heterogeneous Services via the Generic Gateway Agent in order to make a connection from an Oracle session and access a remote SQL Server database table.
Via a live example, show how to backup a database, simulate a failure backup the tail of the database transaction log and perform the restore.

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now