Internet explorer does not open

When I open IE the screen dos not come up as it normally did before. Just a whitish screen
and there are no favorites etc. I am now on my laptop. The desktop is the one failing. Thanks
Who is Participating?
John HurstConnect With a Mentor Business Consultant (Owner)Commented:
Depending on what operating system, you can try uninstalling IE10 temporarily. Go to Windows Updates, Installed Updates, and scroll down looking for IE10. Uninstall the update. That takes you back to IE9.  Ensure it is working correctly.

Now restart and try updating to IE10 again. You can also go to IE11 on Windows 7 and greater.

.... Thinkpads_User
Don ThomsonCommented:
You most likely had a forced I.E. upgrade - The default is to basically show nothing.
Go near the top to the right and right mouse click - You will see Menu, Favorites Bar, etc - Just click on them tho bring everything back.  Under Tools - internet options you can set your home page etc
Make sure Windows is updated....

Try to open Internet Explorer without in safe mode...

Type:  iexplore -extoff  -----> Start ------> Search and hit Enter.

Try to perform a system restore......

windows key + r

Type: sysdm.cpl ------> System Protection -------> System Restore
Train for your Pen Testing Engineer Certification

Enroll today in this bundle of courses to gain experience in the logistics of pen testing, Linux fundamentals, vulnerability assessments, detecting live systems, and more! This series, valued at $3,000, is free for Premium members, Team Accounts, and Qualified Experts.

Thomas Zucker-ScharffSystems AnalystCommented:
Have you tried just opening it without extensions?  Right click on IE and choose to open with extensions disabled (or in some OSes that is a separate shortcut).
63296329Author Commented:
Well I did the update and found a IE one. Uninstalled it. Do not know the level. So i'll maybe do an update. It works ok now. When I start it I get the screen Page can not be displayed.
is web addr ok http//www or defresh in a few minutes. All I do is see the fav of msn and click it. Comes right up. Thanks
John HurstBusiness Consultant (Owner)Commented:
@63296329 - Thanks for the update and I was happy to help.

..... Thinkpads_User
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.