• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 626
  • Last Modified:

SBS 2011 IIS is always redirecting to HTTPS

I have an installation of Small Business Server 2011.

There are a few files in the C:\INetPub\wwwroot folder which need to be served up when we access the server via a hostname like "http://kb.mycompany.com" instead of "https://remote.mycompany.com". For technical reasons, it needs to be served without SSL.

For some reason, I'm getting some very strange redirection behavior when I try to access the site.

If I go to http://kb.mycompany.com, it does show the "IIS 7.0" splashpage, as I want it to, but it redirects to HTTPS. I don't understand why, I don't see anywhere in IIS that says it should do that.

Additionally, if I go to, say, http://kb.mycompany.com/folder/anotherfolder/aaa.html, it actually redirects to https://KB.MYCOMPANY.COM/FOLDER/ANOTHERFOLDER/AAA.HTML, all in uppercase.

That's totally strange, and I don't understand why it is doing that either.

Can anyone point me in the right direction, at least maybe give me an idea of what parts of IIS I should be looking in to try and investigate why this is happening?
0
Frosty555
Asked:
Frosty555
  • 3
  • 2
1 Solution
 
achaldaveCommented:
Check website's SSL options in IIS, is it set to require SSL? check HTTP redirect option. Check error pages,  specially 403 there might be scripted redirect. The redirection can be added to page itself check "AAA.HTML" for any redirection to HTTPS.
0
 
Frosty555Author Commented:
The "Require SSL" checkbox is ticket at the top level.

If I untick it on one of my subfolders, I CAN indeed browse that website using HTTP and it doesn't redirect me!
 
Still, though... if "Require SSL" was ticked I would expect it to throw a 403.4 forbidden error, not redirect to the HTTPS version of the site. And the "all uppercase" redirection is baffling!

There's no custom error pages, no HTTP redirect option, and the page itself isn't doing a redirect (at least not any of MY pages, I don't know what tweaks and modifications have been applied through SBS 2011's Microsoft Exchange installation)...

Judging from what I see in Google Chrome's network debugger it is definitely an HTTP 302 redirect that is coming from the server.

What could be causing the redirect?
0
 
achaldaveCommented:
Check the 403.4 error page, since your site is configured to require SSL and is not throwing 403 error it looks like the 403 error page is customized to redirect. Under error pages section, open properties of 403 and check the filename and path under response action, the file configured there must have redirection.
0
 
Frosty555Author Commented:
Strangely enough, there are no custom 403 error pages configured. I've done that before on other Exchange servers to have OWA redirect to HTTPS, but for some reason in SBS 2011 it isn't necessary.

In any case I figured it out (or at least figured a workaround).

The problem really is that all of these requests are being served by the "Default Web Site" site, which has Require SSL ticked and I'm hesitant to turn that off.

So instead I created a new Site, which does not have Require SSL ticked, and I added all of the hostnames (such as kb.mycompany.com) to the Bindings.

Now this new site is used to serve kb.mycompany.com, and my other hostnames like mail.mycompany.com and remote.mycompany.com are happily served by SBS 2011 like normal
0
 
Frosty555Author Commented:
The big clue was to look at the "Require SSL" tickbox, which was ticked.
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now