?
Solved

Exchange 2013 OWA

Posted on 2014-01-29
21
Medium Priority
?
2,177 Views
Last Modified: 2014-01-30
Brand new server, brand new Exchange installation (with CU3).
(Server 2012 STD - NOT R2)

Hate the new admin interface, but since MS seems determined to make their interfaces less and less user-friendly, I guess I can cope.

Created a new user, but can't log into OWA as that user:  

:-(  Something went wrong!
An unexpected error occurred and your request couldn't be handled.    

X-OWA-Error:  System.Argument.Exception

And so on...

By the way, the administrator mailbox opens just fine (I believe it was created automatically) - and I haven't tried to create another user yet.
So, now what?  I admit that I also haven't yet tried to connect using Outlook, but I am eager to make sure this is working before I spend a lot of time creating users only to have to blow it all away and start all over.

Seems like most problems I run across have been seen by someone here.  Can anyone help?

Thanks...
0
Comment
Question by:RRPELLET
  • 11
  • 9
21 Comments
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 39819975
Any antivirus running on the mailbox or cas servers?
0
 

Author Comment

by:RRPELLET
ID: 39821727
None.  Haven't gotten there yet.
I have more problems than that, however.  Can receive mail from some people, rejected by others as "unroutable address".  Just need to let DNS catch up.  

I am amazed at how different 2013 is, and feel like I have to learn email all over again.  So far, I hate it...

Documentation isn't great, but I've come to expect that from MS.
If anyone has seen a good "Exchange 2013 for beginners" article around, please point it out to me.

Thanks...
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39822332
In EAC | Mailboxes
Select user, then on the right scroll down, is this set?
 Email Connectivity
Outlook Web App: Enabled
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 

Author Comment

by:RRPELLET
ID: 39822351
Yes, it is enabled.
Sorry I forgot to post earlier - been busy with all this.
This morning, after a server reboot, I was able to log into OWA without the reported errors.

I can receive emails now, just can't send.  Was getting event log errors regarding SSL cert, so installed a GoDaddy SSL.  Not getting the event log errors, but still can't send - "550 5.7.1 Unable to relay"
I am betting this is something simple, but I can't find it...


Friggin Microsoft!!

Thanks for your interest!
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39822388
EAC | Recieve Connectors

go thru all these in the list and make sure that your local subnet is included.
0
 

Author Comment

by:RRPELLET
ID: 39822459
Done.  Also restarted the Transport Service, in case it needed it.

Looks like they were all configured for any address anyway (0.0.0.0 - 255.255.255.255) but I put my subnet address in anyway.

No joy, however.  This Exchange server doesn't want to send emails!

Thanks.
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39822605
Are you trying to send thru OWA, or outlook or both?
0
 

Author Comment

by:RRPELLET
ID: 39822613
Just OWA so far.  Need a working email address to get Office licensed now.
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39822629
try running this command in powershell
Get-ReceiveConnector | fl PermissionGroups, AuthMechanism, Bindings, Enabled, RemoteIPRanges, Transportrole, DistinguishedName

send back results
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39822640
Just to be sure by powershell I meant Exchange management shell
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39822678
Are you doing this from a public OWA or are you onsite (or remoted in)
0
 

Author Comment

by:RRPELLET
ID: 39822684
Here you go...

[PS] C:\Windows\system32>Get-ReceiveConnector | fl PermissionGroups, AuthMechanism, Bindings, Enabled, RemoteIPRanges, T
ransportRole, DistinguishedName


PermissionGroups  : ExchangeUsers, ExchangeServers, ExchangeLegacyServers
AuthMechanism     : Tls, Integrated, BasicAuth, BasicAuthRequireTLS, ExchangeServer
Bindings          : {0.0.0.0:2525, [::]:2525}
Enabled           : True
RemoteIPRanges    : {192.168.10.0/24, ::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, 0.0.0.0-255.255.255.255}
TransportRole     : HubTransport
DistinguishedName : CN=Default SERVER1,CN=SMTP Receive Connectors,CN=Protocols,CN=SERVER1,CN=Servers,CN=Exchange
                    Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=WFPMail,CN=Microsoft
                    Exchange,CN=Services,CN=Configuration,DC=domain,DC=local

PermissionGroups  : ExchangeUsers, ExchangeServers
AuthMechanism     : Tls, Integrated, BasicAuth, BasicAuthRequireTLS, ExchangeServer
Bindings          : {[::]:465, 0.0.0.0:465}
Enabled           : True
RemoteIPRanges    : {192.168.10.0/24, ::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, 0.0.0.0-255.255.255.255}
TransportRole     : HubTransport
DistinguishedName : CN=Client Proxy SERVER1,CN=SMTP Receive Connectors,CN=Protocols,CN=SERVER1,CN=Servers,CN=Exchange
                    Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=WFPMail,CN=Microsoft
                    Exchange,CN=Services,CN=Configuration,DC=domain,DC=local

PermissionGroups  : AnonymousUsers, ExchangeServers, ExchangeLegacyServers
AuthMechanism     : Tls, Integrated, BasicAuth, BasicAuthRequireTLS, ExchangeServer
Bindings          : {[::]:25, 0.0.0.0:25}
Enabled           : True
RemoteIPRanges    : {192.168.10.0/24, ::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, 0.0.0.0-255.255.255.255}
TransportRole     : FrontendTransport
DistinguishedName : CN=Default Frontend SERVER1,CN=SMTP Receive
                    Connectors,CN=Protocols,CN=SERVER1,CN=Servers,CN=Exchange Administrative Group
                    (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=WFPMail,CN=Microsoft
                    Exchange,CN=Services,CN=Configuration,DC=domain,DC=local

PermissionGroups  : AnonymousUsers, ExchangeServers
AuthMechanism     : Tls, Integrated, BasicAuth, BasicAuthRequireTLS, ExchangeServer
Bindings          : {[::]:717, 0.0.0.0:717}
Enabled           : True
RemoteIPRanges    : {192.168.10.0/24, ::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, 0.0.0.0-255.255.255.255}
TransportRole     : FrontendTransport
DistinguishedName : CN=Outbound Proxy Frontend SERVER1,CN=SMTP Receive
                    Connectors,CN=Protocols,CN=SERVER1,CN=Servers,CN=Exchange Administrative Group
                    (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=WFPMail,CN=Microsoft
                    Exchange,CN=Services,CN=Configuration,DC=domain,DC=local

PermissionGroups  : ExchangeUsers
AuthMechanism     : Tls, Integrated, BasicAuth, BasicAuthRequireTLS
Bindings          : {[::]:587, 0.0.0.0:587}
Enabled           : True
RemoteIPRanges    : {192.168.10.0/24, ::-ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff, 0.0.0.0-255.255.255.255}
TransportRole     : FrontendTransport
DistinguishedName : CN=Client Frontend SERVER1,CN=SMTP Receive
                    Connectors,CN=Protocols,CN=SERVER1,CN=Servers,CN=Exchange Administrative Group
                    (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=WFPMail,CN=Microsoft
                    Exchange,CN=Services,CN=Configuration,DC=domain,DC=local
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39822705
Try adding another receive connector:
call it something like 'relay test'

under security: check TLS and anonymous only

Under scoping | Remote Network Settings: 192.168.10.0/24 only
Under Scoping | Network adapter bindings: make sure it's all available and port 25

save and try again.  by the way have you restarted all the exchange services lately?
do that after setting up this relay.

Everything else matches my system.
I added the above so I could send mail from some of my personal applications.
0
 
LVL 13

Accepted Solution

by:
ktaczala earned 2000 total points
ID: 39822748
Have you gone thru all the post installation tasks?
Here's the Link:
http://technet.microsoft.com/en-us/library/bb124397%28v=exchg.150%29.aspx
0
 

Author Comment

by:RRPELLET
ID: 39822844
Tried adding the Receive Connector.

Now, when you click Send, they go into Drafts...

Must have missed something important in that Receive Connector...
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39822957
do you have the domain setup correctly? mail.whatever.com?
0
 

Author Comment

by:RRPELLET
ID: 39823022
Since creating that Receive Connector, I am no longer receiving emails, and when I try to send, they go into Drafts.  What's worse, every time I try to delete it (or even disable it), the browser crashes.  So, things are getting worse instead of better.
Of course, that can often be part of the troubleshooting process.  I appreciate your attempts at helping.
Yes, I performed the post-installation tasks.  
Still reading, searching, trying stuff.  Pretty frustrating and just another example of how Microsoft's quality is continuously going downhill.  (Of course, once I get it working I probably won't feel that way again.)  In what world should it take two days to troubleshoot a piece of software?
0
 

Author Comment

by:RRPELLET
ID: 39823110
My problem has been resolved:  it had nothing to do with the mail server after all.  (Figured I'd eat my words, blaming Microsoft!)
The firewall (Untangle) was told to forward port 25 traffic to the mail server's LAN interface.  With lesser-functioning firewalls, it's assumed you mean traffic from the outside hitting port 25 gets forwarded.  This one requires you to specify exactly which port 25 traffic to forward to the mail server's LAN interface, or it forwards ALL port traffic to it.  So none of the intended outgoing port 25 traffic was going out.

Anyway, all the effort you applied to my problem has to be worth something.  I really don't know how the points system works here in E.E. - I am open to suggestions.  While you may not have provided a solution, you did cause me to doubt that the issue was with Exchange, and that led me to the answer.

Thanks so much for your persistence in leading me in the right direction!
0
 

Author Closing Comment

by:RRPELLET
ID: 39823114
Thanks again!
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39823125
Weird, ok try running this.

first you might want to remove that receive connector I asked you to setup.

https://testconnectivity.microsoft.com/
0
 
LVL 13

Expert Comment

by:ktaczala
ID: 39823128
LOL, guess it's easy to over look the "simple" things.  Glad it 's working.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you are trying to access the server, have you ever encountered "The terminal server has exceeded the maximum number of allowed connection" error?  or "The user is attempting to log on to a Terminal Server in Remote Administration mode, but the …
Introduction: Sometimes when I receive a call from my users to solve their problems it is very difficult for me to found their computer IP address. Even finding their computer Host to provide remote support can be a problem.  So I resorted to Goo…
There may be issues when you are trying to access Outlook or send & receive emails or due to Outlook crash which leads to corrupt or damaged PST file. To eliminate the corruption from your PST file, you need to repair the corrupt Outlook PST file. U…
If you are looking for an automated solution for backup single or multiple Office 365 user mailboxes to Outlook data file, then you can use Kernel Office 365 Backup & Restore tool. Go through the video to check out the steps to backup single or mult…

599 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question