trying to access files

I'm trying to get access to some files on a mac drive.
I cant mount the drive in a mac.
However it mounts in Ubuntu.

When I get to the folders I need access, I receive the following message

"The folder contents could not be displayed
You do not have the permissions necessary to view the contents of "Documents"."

Any help to access the files/folders would be appreciated.
citrineAsked:
Who is Participating?
 
TobiasHolmCommented:
"First, make sure that you have hfsprogs installed. Example installation command:

sudo apt-get install hfsprogs
Next, mount or remount the HFS+ drive; commands need to be as follows:

sudo mount -t hfsplus -o force,rw /dev/sdx# /media/mntpoint
or

sudo mount -t hfsplus -o remount,force,rw /mount/point
Finally, if the drive was improperly unmounted or has otherwise become partially corrupted run fsck.hfsplus (provided here by Jayson) as such:

sudo fsck.hfsplus /dev/sdx#
"
0
 
Aditya AroraNetwork & Hardware Commented:
Hi,

Mac uses a file system hfs+ or hfsplus

It doesn`t support linux file permissions. It will always mount read only, meaning you cannot copy stuff to it or from it unless you use some hacks. Try to connect mac.

Aditya
0
 
TobiasHolmCommented:
Have you used a terminal and the command 'sudo'?

Open up a terminal (CTRL+ALT+t).
Type 'sudo ls /media/YOURMACHDNAME'

(Replace YOURMACHDNAME with your media name).
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
citrineAuthor Commented:
TobiasHolm,

I tried:  sudo mount -t hfsplus -o force,rw /dev/sdx# /media/mntpoint

and got the following.

mount: mount point /media/mntpoint does not exist

sudo mount -t hfsplus -o remount,force,rw /mount/point

gives me:

Usage: mount -V                 : print version
       mount -h                 : print this help
       mount                    : list mounted filesystems
       mount -l                 : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
       mount device             : mount device at the known place
       mount directory          : mount known device here
       mount -t type dev dir    : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
One can change the type of mount containing the directory dir:
       mount --make-shared dir
       mount --make-slave dir
       mount --make-private dir
       mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
       mount --make-rshared dir
       mount --make-rslave dir
       mount --make-rprivate dir
       mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using  -L label  or by uuid, using  -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say  man 8 mount .
0
 
TobiasHolmCommented:
>I tried:  sudo mount -t hfsplus -o force,rw /dev/sdx# /media/mntpoint

You must replace sdx# with a valid device (type ls /dev to list your devices). And you must replace /media/mntpoint with a valid mountpoint. First create the mountpoint by typing:

ls /media
sudo mkdir /media/mymountpoint
ls /media
0
 
citrineAuthor Commented:
TobiasHolm,

Trying to fumble my way through.
After I plug in the USB HDD and type ls /dev  "sbd", "sdb1" and "sbd2" appears
So do I put in all three (one at a time)?

Also, after I create the mountpoint, I get:
floppy  floppy0  markabc mymountpoint

 which part do I replace  "/media/mntpoint" with?
0
 
TobiasHolmCommented:
ok. Try this (This will list your hard drives):
sudo fdisk -l

Open in new window

Try to locate your Mac disk, see if you can find a disk that uses hfs. In the example below I've assumed you found your disk on /dev/sdb
sudo mount -t hfsplus -o force,rw /dev/sdb /media/mymountpoint

Open in new window

0
 
citrineAuthor Commented:
TobiasHolm,

I plugged the drive back into the Mac and Abracadabra it works!
Unsure if what you said helped, but happy to give you the points.
0
 
TobiasHolmCommented:
ok, that's great! Thanks!
0
 
Aditya AroraNetwork & Hardware Commented:
Finally what i said works. :)
0
 
citrineAuthor Commented:
Aditya,

I had tried what you suggested dozens of times before posting the question.
It wasn't till after I attempted the advice of TobiasHolm that plugging the drive back into a mac worked. So I gave the points to TobiasHolm, I hope you understand.
0
 
Aditya AroraNetwork & Hardware Commented:
Citrine, Points is no issue i am happy that you get your data back and what i advise is correct. i already tried to access mac drive in Linux system but not able to do that.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.