Solved

fedora lxde

Posted on 2014-01-30
13
769 Views
Last Modified: 2014-02-10
I installed Fedora version 20 about a month ago, and have been very happy with it. So yesterday I wanted to try LXDE for my desktop. I installed it using this command at the terminal

yum install @lxde-desktop

and it went fine, with no errors.
However, I when I click on system settings, nothing happens. So I did some research and if I understand this correctly, LXDE should have a control center. Which I don't have, so I googled how to install it, and only found Ubuntu instructions.
So my question is, how do you install the control center for LXDE?
0
Comment
Question by:JeffBeall
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 3
  • 2
13 Comments
 
LVL 31

Expert Comment

by:farzanj
ID: 39820725
Looks like your new desktop is installed, just you need to switch to it

Did you try

switchdesk command

Or you can change /etc/sysconfig/desktop file to make it default

You can try suggestion in this link.  It presents modification of the above file.
http://fedoraproject.org/wiki/LXDE
0
 
LVL 1

Author Comment

by:JeffBeall
ID: 39820808
I switch to LXDE when I log in. There is a gear icon, that when I click on it list the desktops available. That is where I choose LXDE, and it keeps that selection until you choose something different.
Also, I know I'm on LXDE because it looks completely different from Gnome.
0
 
LVL 31

Assisted Solution

by:farzanj
farzanj earned 250 total points
ID: 39820815
I meant the switchdesk command.

Also, you basically appear to have it.  As a checklist, I have given you the link above to compare your configurations to.
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 1

Author Comment

by:JeffBeall
ID: 39821077
the thing is, I can't find anything about the control center at the link you provided.
I get the impression that it isn't installed.
I'm hoping it's the control center that I need, because I don't have things like the sound control panel to adjust the volume.
0
 
LVL 44

Expert Comment

by:Darr247
ID: 39821750
When you select your username at the logon screen, do more options appear on the task bar?

I can't remember what package I installed to get those extra options, but the other desktops I had installed could be selected from the 'Sessions' picklist at the logon screen, then I would enter my password and logon to the desktop selected there.  I remember those options did not appear until after the username was selected/clicked on, though.

edit: on further investigation, that desktop environment chooser should be installed by default... if you don't see it, try using the groupinstall command with yum.
e.g.
$ su -c 'yum groupinstall lxde'
0
 
LVL 1

Author Comment

by:JeffBeall
ID: 39823047
well, the groupinstall thing didn't work, it said something about there was nothing to do. however, i came across something interesting.
So when i am in the gnome environment, i have the sound volume control and pretty much everything works. the problem is it is an older laptop and runs gnome ok, but at times a little sluggish
Then i tried lxde and there is a noticeable increase in performance, but no volume control, UNLESS I log out, then in the login screen there is a volume control! It's not very helpful though since, when i am logged in, i would like to adjust the volume.
in the KDE environment, everything works except the wireless. It shows my saved wireless settings, but for the life of me, i couldn't find a connect button.
I even tried the xfce desktop, but I actually liked the lxde environment better, and the sound issue was the same as lxde.
So for some crazy reason, for lxde the sound adjustment control panel only shows in the login screen. if i could somehow get it in the lxde environment it would be perfect because like i say, it performs great on my laptop, and i even like how it looks.
0
 
LVL 1

Author Comment

by:JeffBeall
ID: 39827152
so, no other ideas?
0
 
LVL 44

Expert Comment

by:Darr247
ID: 39827691
As I asked in http:#a39821750
"When you select your username at the logon screen, do more options appear on the task bar?"
0
 
LVL 1

Author Comment

by:JeffBeall
ID: 39828661
sorry, I guess I missed that.
at the login screen, at the top of the screen is the time, then there is an access icon, a sound icon, brightness, battery and power icon. Then the login button.
then once I login, I can't find a sound control panel, or icon.
0
 
LVL 44

Accepted Solution

by:
Darr247 earned 250 total points
ID: 39828705
When the login screen comes up, you select your username.
i.e. just click on your username...  do not enter your password.
Stop.
Look at the task bar along the bottom of the screen.
Have more options appeared on the task bar?
0
 
LVL 1

Author Comment

by:JeffBeall
ID: 39841720
I'm sorry, I got distracted and forgot to try this. I'll try it tonight.
0
 
LVL 1

Author Comment

by:JeffBeall
ID: 39845761
"just click on your username...  do not enter your password.
Stop.
Look at the task bar along the bottom of the screen.
Have more options appeared on the task bar? "

no, nothing appears on the task bar on the bottom of the screen
at the top of the screen there is the time, an easy access panel for things like high contrast, zoom, etc,
then next to that is the sound, battery, and power panel
I just had a thought though. I added LXDE after the fact. I will try downloading the ISO for LXDE linux, instead of just the desktop.
0
 
LVL 1

Author Closing Comment

by:JeffBeall
ID: 39848988
so it turns out that when I install lxde from the ISO, and not just as software added after installing Fedora, NOW I have the sound control panel.
There's always something though. When I installed Fedora I was able to get my Dell e6400 wireless to work. Now using the exact same way that I setup my wireless in Fedora, I can't seem to get the wireless to work.
But that would be a question for another time.
Thank you for your help.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Ubuntu Apache Webserver - File Permissions 5 77
Linux script delete files 3 60
how to include conditional log rotate in liunx. 17 73
Shrink Linux Swap File Size CentOS 10 33
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question