Solved

Out Of Office - Exchange 2010 SP3

Posted on 2014-01-30
3
919 Views
Last Modified: 2015-02-01
SBS2011
Just upgraded from Exchange 2010 SP1 to SP3.

Out of Office does not work (Outlook) but does work from OWA.

Checked that the 3rd party SSL Cert does have Sub Alt. Name set to Autodiscover.OURCLIENT.com

As well, we have the external DNS A Record, and Internal A record set.

This all worked fine, until the recent upgrade to Service Pack 3.....seems to be that maybe the EWS directory and/or web.config file could be the problem?

Re-created EWS Directory/Re-created Autodiscover Virtual Directory

Checked IIS, cannot browse to EWS...receive following error message:

Parser Error Message: Could not load file or assembly 'Microsoft.Exchange.Security, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 2391:                  </buildProviders>
Line 2392:                  <assemblies>
Line 2393:                        <add assembly="Microsoft.Exchange.Security, Version=14.0.0.0, Culture=neutral, publicKeyToken=31bf3856ad364e35" />
Line 2394:                  </assemblies>
Line 2395:            </compilation>
 
 Source File:  C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\exchweb\EWS\web.config    Line:  2393



Not sure how much to read into this error, and if's the root issue.
OWA Works fine, and as well can set Out of Office here...but not within Outlook Clients.

Also noticed Mailtips are not working now after the SP3 upgrade.....anyway to just roll this back to SP1 also....never had this happen but this SP3 upgrade was a nightmare.....
0
Comment
Question by:Jenlor
3 Comments
 
LVL 4

Accepted Solution

by:
milikad earned 500 total points
ID: 39823585
1. Replacing the web.config file from another exchange server with same version (Exchange versions along with service pack and rollup updates) will help to resolve the issue

2. Once this is done, related to OOF, check the output of Test Email Autoconfiguration in Outlook and check the OOF URL, if it is found set to internal FQDN, correct the same. Even check if there are any proxy settings in Internet Explorer, if present remove them as well and then test.
0
 

Author Closing Comment

by:Jenlor
ID: 39824433
I did find, while digging through the file....that the InstallDir was set to %%.
So instead of File://// I updated this to the Actual Path (on Local C:\) and tested.
This now works successfully.
0
 
LVL 7

Expert Comment

by:Senior IT System Engineer
ID: 40582385
thanks for sharing it here guys.

So in this case, do we just change the web.config of the installDir to the previous values as before the update ?
0

Featured Post

3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
how to add IIS SMTP to handle application/Scanner relays into office 365.

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question