Solved

Site to Site VPN, IP PBX Gateway not tunneling

Posted on 2014-01-31
6
969 Views
Last Modified: 2014-02-06
In the Main Site I have a LAN with a number devices, One of these devices is an IP PBX Gateway. I want the IP Phones in Site A to register with this IP PBX Gateway. From the Main Site I am able to see all the IP Phones present in site A, but from site A I am not able to see the IP PBX Gateway but I can see other device such as PCs and IP cameras. In the Main Site I have a Cisco ASA 5510 and in Site A I have TL-R600VPN, an IP SEC VPN has been established between them. How can I make the IP PBX Gateway be visible from Site A? I have tried an ACL to permit TCP/UDP SIP, but it haven;t worked. Site A static public IP is 195.158.xxx.172 private IP is 192.168.10.0/24, Main site public static IP is 213.165.xxx.76 and private IP of the Main Site is 192.168.0.0/24, and the private IP of the IP PBX Gateway is 192.168.0.201 The following is the current configuration of the Cisco ASA5510.

esult of the command: "SH RUN"

: Saved
:
ASA Version 8.2(1)
!
hostname ciscoasa
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 speed 100
 nameif outside
 security-level 0
 ip address 213.165.xxx.76 255.255.255.224
!
interface Ethernet0/1
 speed 100
 nameif inside
 security-level 100
 ip address 192.168.0.205 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
ftp mode passive
dns domain-lookup outside
dns server-group defaultDNS
 name-server 212.56.xxx.132
 name-server 212.56.xxx.196
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
access-list allow_inside_in extended permit tcp 192.168.0.0 255.255.255.0 any eq www
access-list allow_inside_in extended permit tcp 192.168.0.0 255.255.255.0 any eq https
access-list allow_inside_in extended permit udp 192.168.0.0 255.255.255.0 any eq domain
access-list allow_inside_in extended permit tcp 192.168.0.0 255.255.255.0 any eq 3389
access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_access_in extended permit object-group TCPUDP any 213.xxx.177.64 255.255.255.224 eq sip
pager lines 24
logging enable
logging asdm informational
mtu management 1500
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 195.158.xxx.172 192.168.0.201 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 213.165.177.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 195.158.xxx.172
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp enable inside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 212.56.xxx.132 212.56.xxx.196
!
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
dhcpd address 192.168.0.10-192.168.0.200 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 195.158.xxx.172 type ipsec-l2l
tunnel-group 195.158.xxx.172 ipsec-attributes
 pre-shared-key *
!
class-map icmp-class
 match default-inspection-traffic
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map icmp_policy
 class icmp-class
  inspect icmp
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect netbios
  inspect tftp
!
service-policy global_policy global
service-policy icmp_policy interface outside
prompt hostname context
Cryptochecksum:954193635292bf2d685eabd630541e89
: end
0
Comment
Question by:bixkli
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 14

Accepted Solution

by:
Don Thomson earned 500 total points
ID: 39823861
Try setting your subnet to 255.255.0.0  - You are trying to go from one subnet to another using 255.255.255.0 -- Ain't going to get there from here  as the saying goes
0
 

Author Comment

by:bixkli
ID: 39823899
The subnet of the IP PBX, of Site A or of The Main Site?
0
 
LVL 15

Expert Comment

by:Robert Sutton Jr
ID: 39824095
I just want to clarify your issue from above:
From Main to Site A you can see any/all devices no problems.
From Site A to Main you can see any and all devices EXCEPT the Ip PBX gateway which is where you remote phones need to pull their configs or register from?
0
Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

 
LVL 28

Expert Comment

by:asavener
ID: 39824189
I think your problem is here:
static (inside,outside) 195.158.xxx.172 192.168.0.201 netmask 255.255.255.255


Cisco order of operations has NAT take place before crypto, so 192.168.0.201 is being NAT'd to 195.158.xxx.172, and then the traffic doesn't match your tunnel rule.


Why is your PBX gateway published to the Internet?
0
 
LVL 28

Expert Comment

by:asavener
ID: 39824199
OK, your outside access in rule shows no need for inbound traffic, so I'm thinking it's published to that address in order to allow it to reach some other site on the public Internet.
0
 

Author Closing Comment

by:bixkli
ID: 39841215
I had different subnets on the same Lan, and it was confusing all the traffic. Thanks
0

Featured Post

Resolve Critical IT Incidents Fast

If your data, services or processes become compromised, your organization can suffer damage in just minutes and how fast you communicate during a major IT incident is everything. Learn how to immediately identify incidents & best practices to resolve them quickly and effectively.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VOIP gateways - feedback 23 125
Remote Desktop Services in AWS 4 53
Port status messages not appearing in console 11 59
connect to cisco 2690 series 6 76
I've written this article to illustrate how we can implement a Dynamic Multipoint VPN (DMVPN) with both hub and spokes having a dynamically assigned non-broadcast multiple-access (NBMA) network IP (public IP). Here is the basic setup of DMVPN Pha…
For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question