Solved

New vCenter 5.5 install fails with vctomcat errors: vctomcat service NOT STARTED Error: 1068

Posted on 2014-01-31
9
4,894 Views
Last Modified: 2014-02-03
I have just installed 5.5 with a embedded database , basicly the default install on a 2008 R2 server ,

it fails to start the web services and the vcenter services






this is the install log


VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 --- CA exec: VMCheckSqlExpInstalledVersion
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Setting property SQLEXP_UPGRADE_REQUIRED =
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Getting Property MSDE_INSTANCE = VIM_SQLEXP
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Getting Property SQL_EXP_VERSION = 10.50.2500.0
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Util_CompareFileVersion: version1: 10.50.2500.0, version2: 10.50.2500.0
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 End Logging
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Begin Logging
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 --- CA exec: VMStartTomcatImmediate
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Getting Property TOMCAT_SERVICENAME = vctomcat
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Getting Property SERVICE_START_TIMEOUT =
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 StartServices::ServiceNames: vctomcat
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Srvc_IsService
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvcManager
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvc
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Srvc_IsService::done Service EXISTS
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Srvc_StartService::ServiceName: vctomcat TimeOut: 1200 sec.
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Srvc_IsServiceRunning
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Srvc_IsServiceStatus::serviceStatus: 4
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Srvc_IsService
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvcManager
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvc
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Srvc_IsService::done Service EXISTS
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvcManager
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvc
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Srvc_IsServiceRunning::done Service is NOT RUNNING
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvcManagers
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvcManager
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvcs
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 OpenSrvc
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 Service Status: 1
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 IsLocked
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 QueryLockStatus
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 IsLocked::done Service NOT LOCKED Error: 0
VMware VirtualCenter-build-1476327: 01/31/14 08:05:25 StartSrvc::NumArgs: 0
VMware VirtualCenter-build-1476327: 01/31/14 08:07:45 StartSrvc::ERROR_SERVICE_DEPENDENCY_FAIL The service depends on another service that has failed to start Error: 1068
VMware VirtualCenter-build-1476327: 01/31/14 08:07:45 StartSrvc::done Res: 0
VMware VirtualCenter-build-1476327: 01/31/14 08:07:45 Could not start service.
VMware VirtualCenter-build-1476327: 01/31/14 08:07:45 Srvc_StartService::vctomcat service NOT STARTED Error: 1068
VMware VirtualCenter-build-1476327: 01/31/14 08:07:45 StartServices::done ret: 1603
0
Comment
Question by:NAMEWITHELD12
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
9 Comments
 
LVL 28

Expert Comment

by:asavener
ID: 39823921
I think this is your problem:  VMware VirtualCenter-build-1476327: 01/31/14 08:07:45 StartSrvc::ERROR_SERVICE_DEPENDENCY_FAIL The service depends on another service that has failed to start Error: 1068

You need to find the dependency, and figure out why it isn't starting.

Check the tomcat service, and look for dependencies.  Make sure that IIS isn't already installed/running.
0
 
LVL 1

Author Comment

by:NAMEWITHELD12
ID: 39823969
thanks for the quick reply , I appreciate the help!!

I dont see any tomcat service , however there is the "Vmware virtual center manamgemt webserivces" and that will not start

it depends on the vmware server service that and that will not start
0
 
LVL 28

Accepted Solution

by:
asavener earned 500 total points
ID: 39824005
OK.  Browse to your C: drive.  Select Organize-> Folder and search options -> View.  Select "show hidden files."  Click Apply.  Click Apply to folders.  Click OK.

Now look at your C: drive and you should see a folder called ProgramData.  Browse to ProgramData->VMware->VMware VirtualCenter->Logs.  Change the view to sort by Date Modified.  Near the top you should see a file called vpxd-<somenumber>.log  Open it, and post the last 10 lines or so here.
0
Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

 
LVL 13

Expert Comment

by:Abhilash
ID: 39824085
Can you go to services and Right Click them, Go to properties and then change the Log on user to a local administrator or Domain administrator and see if it starts.
0
 
LVL 1

Author Comment

by:NAMEWITHELD12
ID: 39824280
I have used the highest rights account that I have not domain admin tho


still the same error


this is the error on the install log

Property(C): SourcedirProduct = {E1F05550-4238-4378-87F0-105147A251D9}
Property(C): OutOfDiskSpace = 0
Property(C): OutOfNoRbDiskSpace = 0
Property(C): PrimaryVolumeSpaceAvailable = 0
Property(C): PrimaryVolumeSpaceRequired = 0
Property(C): PrimaryVolumeSpaceRemaining = 0
Property(C): USE_FQDN = 1
Property(C): MSDE_INSTALLED = 1
Property(C): TEMPDIR = C:\Users\Bs\AppData\Local\Temp\{E1F05550-4238-4378-87F0-105147A251D9}\vc
=== Logging stopped: 1/31/2014  10:26:09 ===
MSI (c) (F4:AC) [10:26:09:853]: Note: 1: 1729
MSI (c) (F4:AC) [10:26:09:853]: Product: VMware vCenter Server -- Configuration failed.

MSI (c) (F4:AC) [10:26:09:854]: Windows Installer reconfigured the product. Product Name: VMware vCenter Server. Product Version: 5.5.0.39885. Product Language: 1033. Manufacturer: VMware, Inc.. Reconfiguration success or error status: 1603.

MSI (c) (F4:AC) [10:26:09:877]: Grabbed execution mutex.
MSI (c) (F4:AC) [10:26:09:877]: Cleaning up uninstalled install packages, if any exist
MSI (c) (F4:AC) [10:26:09:881]: MainEngineThread is returning 1603
=== Verbose logging stopped: 1/31/2014  10:26:09 ===
0
 
LVL 1

Author Comment

by:NAMEWITHELD12
ID: 39824554
e has these problems:
-->
--> * A certificate in the host's chain is based on an untrusted root.
-->
--> * self signed certificate in certificate chain)
2014-01-31T12:06:13.190-05:00 [01048 error '[SSO][SsoFactory_CreateFacade]'] Unable to create SSO facade: SSL Exception: Verification parameters:
--> PeerThumbprint: C3:70:53:83:C7:80:2C:3A:FA:D0:6B:67:8A:7C:B9:BB:B2:EE:4C:35
--> ExpectedThumbprint:
--> ExpectedPeerName: e07r7m-evmvc01.ent.ds.gsa.gov
--> The remote host certificate has these problems:
-->
--> * A certificate in the host's chain is based on an untrusted root.
-->
--> * self signed certificate in certificate chain.
2014-01-31T12:06:13.190-05:00 [01048 warning 'VpxProfiler'] Vpxd::ServerApp::Init [Vpx::Common::Sso::SsoFactory_CreateFacade(sslContext, ssoFacadeConstPtr)] took 15175 ms
2014-01-31T12:06:13.190-05:00 [01048 error 'vpxdvpxdMain'] [Vpxd::ServerApp::Init] Init failed: Vpx::Common::Sso::SsoFactory_CreateFacade(sslContext, ssoFacadeConstPtr)
--> Backtrace:
--> backtrace[00] rip 000000018018cd7a
--> backtrace[01] rip 0000000180106c48
--> backtrace[02] rip 000000018010803e
--> backtrace[03] rip 00000001800907f8
--> backtrace[04] rip 0000000000505bac
--> backtrace[05] rip 0000000000526722
--> backtrace[06] rip 000000014076acfa
--> backtrace[07] rip 000000014076481c
--> backtrace[08] rip 000000014099619b
--> backtrace[09] rip 000007feffbea82d
--> backtrace[10] rip 000000007740652d
--> backtrace[11] rip 0000000077afba01
-->
2014-01-31T12:06:13.192-05:00 [01048 warning 'VpxProfiler'] ServerApp::Init [TotalTime] took 20376 ms
2014-01-31T12:06:13.192-05:00 [01048 error 'Default'] Failed to intialize VMware VirtualCenter. Shutting down...
2014-01-31T12:06:13.210-05:00 [01048 info 'vpxdvpxdSupportManager'] Wrote uptime information
2014-01-31T12:06:16.819-05:00 [02468 warning 'VpxProfiler' opID=SWI-56f32f43] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
2014-01-31T12:06:28.820-05:00 [01260 warning 'VpxProfiler' opID=SWI-31169898] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
2014-01-31T12:06:40.821-05:00 [06104 warning 'VpxProfiler' opID=SWI-6a5d128c] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
2014-01-31T12:06:52.822-05:00 [01260 warning 'VpxProfiler' opID=SWI-6d7d4b3] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
2014-01-31T12:07:04.823-05:00 [06104 warning 'VpxProfiler' opID=SWI-55e83917] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
2014-01-31T12:07:16.825-05:00 [01260 warning 'VpxProfiler' opID=SWI-3113c398] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
2014-01-31T12:07:28.826-05:00 [02468 warning 'VpxProfiler' opID=SWI-35702e2f] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
2014-01-31T12:07:40.827-05:00 [05108 warning 'VpxProfiler' opID=SWI-4b63962d] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
2014-01-31T12:07:52.828-05:00 [06104 warning 'VpxProfiler' opID=SWI-6c4f3258] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms
2014-01-31T12:08:04.829-05:00 [02468 warning 'VpxProfiler' opID=SWI-bc5816b] VpxUtil_InvokeWithOpId [TotalTime] took 12001 ms
2014-01-31T12:08:13.216-05:00 [01048 info 'Default'] Forcing shutdown of VMware VirtualCenter now
0
 
LVL 1

Author Comment

by:NAMEWITHELD12
ID: 39824640
interesting if I goto the webclient URL I see a different physical site ( texas) and I am in florida i think the SSO install got hosed
0
 
LVL 1

Author Comment

by:NAMEWITHELD12
ID: 39825519
fixed now !

reinstalled it all

thanks all
0
 
LVL 1

Author Closing Comment

by:NAMEWITHELD12
ID: 39829305
the solution was in the VPXD.log

once I forced this error and looked at this log for the error it pointed to a cetificate error on the SSO. I re installed SSO and vcenter and all is good!!!
0

Featured Post

The Ultimate Checklist to Optimize Your Website

Websites are getting bigger and complicated by the day. Video, images, custom fonts are all great for showcasing your product/service. But the price to pay in terms of reduced page load times and ultimately, decreased sales, can lead to some difficult decisions about what to cut.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question