External domain same as internal domain Wordpress issue

I have a internal domain name of princeprecision.com, which matches the domain name of our external website. When I go to the website internally it want to display the IIS7 start page. From what I have gathered the solution is to add an www "A" record to the forward lookup zone of the DNS that points to the IP address of the website. Here is where the problem starts.

My website is hosted through godaddy on a shared hosting plan. The ip address is 50.62.37.1. When I go to that IP address I get a "page ok" and that is it. Not sure how to resolve this issue.

Thanks in advance for your help.
Robert FrancisDirector of Continuous ImprovementAsked:
Who is Participating?
 
DrDave242Commented:
With the www host record in place within the princeprecision.com domain (and without the CNAME record), what do you see on an internal machine when you try to browse to www.princeprecision.com? Do you get the same "Page OK" page that you see when you browse to the IP address, or something different?

I'm asking because I set up a princeprecision.com forward lookup zone in my test environment, created a www host record within it (using the IP address you gave above), and was able to browse to your site with no problems. Even though I'm coming from outside your network, my internal DNS server is doing the same thing yours is, so there shouldn't be any difference.
0
 
Zephyr ICTCloud ArchitectCommented:
Try to add a cname record www.princeprecision.com (or external.princeprecision.com) that points to princeprecision.com using the IP-address will not work because it is shared hosting, this means that IP-address is used for more then 1 website.
0
 
Robert FrancisDirector of Continuous ImprovementAuthor Commented:
That does not work. Pointing the cname to princeprecision.com just points it back to the server.
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
DrDave242Commented:
You've verified that creating the www host record won't allow you to correctly browse the website from inside the office? Browsing directly to the IP address certainly won't work because of the shared hosting, but if you create the host record and then browse to www.princeprecision.com, the HTTP request should allow the web server to direct you to the correct site.
0
 
Zephyr ICTCloud ArchitectCommented:
There's a few other options you might try:

1. Install IIS on the DC and re-direct (not really ideal and sometimes not allowed due to Security concerns)

2. Registry edits

More info about these options: http://www.itgeared.com/articles/1005-active-directory-domain-name/
0
 
Robert FrancisDirector of Continuous ImprovementAuthor Commented:
DrDave - Yes I am sure
0
 
DrDave242Commented:
Sorry - I forgot about this one. Have there been any changes in your situation?
0
 
Robert FrancisDirector of Continuous ImprovementAuthor Commented:
No changes. It has really been a problem. I have to review and make changes to the website internally using an ipad on 3g.
0
 
Robert FrancisDirector of Continuous ImprovementAuthor Commented:
I will try this in the morning and let you know. Thanks
0
 
DrDave242Commented:
How's everything looking?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.