Solved

Problems mailing an email template to recipients

Posted on 2014-01-31
23
200 Views
Last Modified: 2014-04-04
This is a follow up question to Blue Devilfan on ID: 39728886.
I thought that the email template was fine, until I actually mailed it to someone.   There are a couple of problems - though these may be related:

For some reason when it arrives in someone's mailbox, the template is not attached and only the subject wording appears in the Subject line.  Also, the word David appears - and I don't know how to remove it.  
So, I am calling up the template from the library, filling in the fields, both for dropdown and free text and then mailing it out.
The recipient sees a blank email with 'Dave' - and the template details have disappeared.
When I check my Sent box it is the same issue - the template and the information entered into it has disappeared as if I never completed it.  There is just a blank email from me (apart from subject line - and 'Dave').
0
Comment
Question by:Lomed_Geoff
  • 12
  • 11
23 Comments
 
LVL 76

Expert Comment

by:David Lee
ID: 39825028
Hi, Geoff.

Where did you end up publishing the form?
0
 

Author Comment

by:Lomed_Geoff
ID: 39827828
My IT dept created a public folder for me on Outlook that would be visible to all company members.  This was called "CRS".  This then appeared in the same place as the Libraries on the area in Outlook you directed me to - (More Forms etc). They said that they couldn't use one of the existing libraries for some reason.   I attach a file with two screenshots to show you where they created CRS and how I can then find it under More Forms.  I renamed your template to CRS Lomed Template Test as you can see in this example.
outlook-screenshot.docx
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39829207
Are the items that use this form being delivered to the public folder?
0
 

Author Comment

by:Lomed_Geoff
ID: 39829769
Not sure what you mean by 'items':  If you mean the lists that populate the drop down menus, not the original lists.  These have been made into horizontal format and pasted into the form in the design before it is published.  Is this what you meant?
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39829887
No, I mean the messages that use this form.
0
 

Author Comment

by:Lomed_Geoff
ID: 39830098
I didn't yet set up the part where, when they send their email out it also goes to the public mailbox - though that is the intention.  so farI have only tested the calling up of the template, entering data into it and sending it to a couple of addresses.  Then seeing what the recipients see.  So nothing arriving in the Pulic Folder.
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39830197
Then that's why you aren't seeing the form or the form data.  With the form published to just that one public folder, the message must be in that folder for the form to work.
0
 

Author Comment

by:Lomed_Geoff
ID: 39830345
Sorry  I am not sure that I follow:  Do you mean that when someone calls up the template, fills it in, and emails it to someone else - it is essential that the email is also sent to the public folder?  And if that is so, how to ensure that this happens - does that folder have an email address like a person or does it have to be somehow programmed in? The preference must be to get it to default to there so that the person filling in the template doesn't have to worry - or even have visibility to that aspect.

Also, how do we get the word David removed from the message portion?

Thank you Bluedevilfan
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39830427
Do you mean that when someone calls up the template, fills it in, and emails it to someone else - it is essential that the email is also sent to the public folder?

Yes, because that's the only place the form has been published to.  If the form were published to the organizational forms library or to each user's personal forms library, then the form would work from any folder.  But, since the form was only published to the one public folder, then that's the only folder the form will work in.

Also, how do we get the word David removed from the message portion?

Are you saying that "David" appears in the body of each new message you create using this form?
0
 

Author Comment

by:Lomed_Geoff
ID: 39830444
Yes, "David" appears in the body of each new message.  
RE getting the emails also sent to the Public Folder:  Please can you also tell me how to ensure that this happens - does that folder have an email address like a person or does it have to be somehow programmed in? The preference must be to get it to default to there so that the person filling in the template doesn't have to worry - or even have visibility to that aspect.
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39830499
Yes, public folders have an email address.  You can pre-populate that into the message if you want.  

Open the form in the form designer.  Right-click on the "To" field and select "Properties".
Go to the "Value" tab.  Check the "Set the initial value ..." box and enter the address you want it to contain.

You can use the same approach with the body field to get rid of David.  Set the initial value to nothing.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:Lomed_Geoff
ID: 39841943
Hi - sorry for the delay:  It took a while to get them to enable the public folder - CRS to receive emails to its address.  I sent the completed email template to that folder, to another person in the organisation and to me.  In  my own inbox it did't work.  But it did in the CRS folder.  So a lot of progress - but we need it to also be visible to the line manager recipient - not just to the CRS folder.

Also - are you able to be more explicit about how to get rid of David in the Body Field?  The name doesn't appear in the template itself only on the body of the covering email and I can't see where I might find the properties for that.  Also which field would it be.  There isn't one called "Body Field", for example - not that I think you meant that anyway.  Thanks
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39842750
but we need it to also be visible to the line manager recipient - not just to the CRS folder.

Then you'll need to publish the form to the line manager's personal forms library.

Also - are you able to be more explicit about how to get rid of David in the Body Field?

1.  Open the form in the form editor
2.  Right-click on the message body field and select Properties
3.  Select the Value tab
4.  Check the box labeled "Set the initial value of this field to:"
5.  Enter " " in the textbox next to the Edit button
6.  Click OK

If that doesn't solve the problem, then I must not understand what the problem is.
0
 

Author Comment

by:Lomed_Geoff
ID: 39849900
really sorry but I don't know what you mean by Message Body Field:  Do you mean the area of the template where we put the drop down boxes.  ie to right click on the spaces between these boxes?  When I do that I get a box that contains Properties and Advanced Properties - but the Properties option is greyed out.  And in Advanced Propoerties there isn't the Value tab you mention.
Or, do you mean clicking on the covering email that is created when the template is "sent" and where the word "David" appears - but I can't get to that through the library - I only ever see that in the sent box after the template has been sent. (and also in the public folder) - and right clicking there doesn't bring up properties either.
I believe the issue is from the original creation of this - I assumed David was your name(?) and therefore an easy fix at your end perhaps?  Could you try to delete it from your end and send me a version without the signature?  I have not made any real changes to what you sent me, that I could not do again.  it would be worth it for me.
Thanks
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39849991
No, that's not what I mean.  If you open the form in the form editor, then you should see something like this

Screen shot of a message form in the form editor
The message body field is the form field where you would enter/see the message you type.  In the screen shot, it's the area inside the bounding box (the shaded line with the resizing handles).

If that's not where "David" is appearing, then I don't understand what you're seeing.  A screenshot would help.
0
 

Author Comment

by:Lomed_Geoff
ID: 39854246
Hi - I attach a powerpoint file with two screenshots.  The first slide shows what I see when I open the file from the folder to which I published it ("CRS" folder) and then go into the Developer/Design This Form:  David doesn't appear anywhere.

The second slide shows the same email template which was sent to me, and a colleague as well as to the CRS folder - and shows the outlook view of it sitting in CRS.  Because as you rightly said, it is published in that folder, if I were to open it from here - it would show the template.  But when it is sitting in Outlook without being opened - you see exactly what is shown here on the right hand view - it looks like a blank email with David written there.

I don't know any David so I have to assume it is somehow embedded in the file you sent me - and which I re-attach for your convenience should that be the case.

Regards
Geoffrey
LomedGeoff1.oft.txt
Presentation3.pptx
0
 

Author Comment

by:Lomed_Geoff
ID: 39877068
Hi BlueDevilFan - were you able to look at the screenshots I sent you on 12th Feb?  I needed to update my credit card details so I am not sure if you always had visibility - but everything seems okay now.  Thanks
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39885189
Hi, Geoff.

First, I apologize for taking so long to respond.  

I looked at your screenshots and now I understand.  The reason you don't see the body field is because it's been removed.  My name is David and that's what I typically use as my signature.  I must have saved it into the form by mistake when I edited it.  The only reason you're seeing David is because Outlook defaults to the standard message form when it can't find the specified custom message form.  I can remove David from the form if you want, but it's really a non-issue since to be useful the form needs to be published and once properly published you won't ever see the body.  It's your call.
0
 

Author Comment

by:Lomed_Geoff
ID: 39889758
Hi David,
Ideally I would like people to see the template even when it sits unopened in their inbox.  Is saving this into the form also causing the situation on the second screenshot in my attachment Presentation3?    This shows that the preview pane show a blank email with David, even before they have clicked to open the email.
I would like them to see the template in the preview pane.  
I am thinking then that if you remove whatever you saved into the form, that this might solve the problem.
Especially as you are saying that it can't find the specified custom message form.  I don't want there to be any other message beyond the template itself.  So yes please would you remove it?  
I know you say that once properly published we shouldn't be seeing this body - but I think it has now been properly published to this mail folder - and we are still seeing it.  I would like to see if the update you send solves that.
Thank you so much.
Geoffrey
0
 
LVL 76

Accepted Solution

by:
David Lee earned 145 total points
ID: 39944881
Geoffrey,

Custom forms can't be shown in the reading pane.  Outlook only displays an item's default form type in the reading pane.  For example, a custom message form will display as the standard message form in the reading pane.  There is no way I know of to work around that.  

I've edited the form and removed "David" from the body.  Remember to remove the .txt portion of the file name to change to a .oft file.
LomedGeoff2.oft.txt
0
 

Author Comment

by:Lomed_Geoff
ID: 39951274
Thank you for this - yes the "David" has now disappeared.  I am hearing that the reason that we may be getting these visibility issues to those cc'd outside of the published folder, is that Microsoft have moved away from supporting email templates in their later versions of Outlook.  
So something that would have easily worked 3 years ago will not now.  Have you heard of this at all?
Thanks
0
 

Author Closing Comment

by:Lomed_Geoff
ID: 39978511
Hi Dave
Thanks for removing the name. We have been able to use this.  Re the lack of display on the reading pane view, we will have to train them to double click to view.  Best Wishes  Geoff
0
 
LVL 76

Expert Comment

by:David Lee
ID: 39978774
You're welcome, Geoff.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Granting full access permission allows users to access mailboxes present in their database. By giving full access permission one can open and read the content of any mailbox but cannot send emails from that mailbox.
Technology opened people to different means of presenting information, but PowerPoint remains to be above competition. Know why PPT still works today.
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now