IIS redirection

I have created a new website in IIS 7 under the Default Website. Internally, from my desktop, when I go to the url - "http://url.domain.com" I get the Welcome IIS 7 homepage. On the IIS server if I browse website the website comes up fine though.
In my browser if I add to the end of the url as "http://url.domain.com /applicantionname/login" the page appears  correctly.
How can I make that happen automatically?
Thanks.
LVL 7
tolinromeAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Emmanuel AdebayoConnect With a Mentor Global Windows Infrastructure Engineer - ConsultantCommented:
The issue here is the way how you set up your content directory structure.

You will need to create your folder structure s such that  it points to the contents of your application. and then you will add whatever extention is loading you login page in the default document if it not default.aspx, index.asp etc.

I hope this helps.

Regards
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Create a new website outside the default website called http://application.domain.com and have it look at your website directory.

You COULD copy this code to a index.html under the default website and make it standard page in IIS to open BUT there is a risk you break other websites under the default.
So unless you dont know, continue but document what you have done so you can reverse it if disaster strikes

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
<meta http-equiv="refresh" content="0;URL=http://url.domain.com /applicantionname/login" />
<title></title>

</head>
<body>

</body>
</html>

Open in new window

0
 
tolinromeAuthor Commented:
Sorry for the confusion but it is a website outside the default website and not under it. When I wrote in the first post that it was under I didn't mean exactly under, but it's a totally separate website. Thanks.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
Patrick BogersDatacenter platform engineer LindowsCommented:
Cool. In that case. Can you (in bindings) add url.domain.com on port 80?
0
 
tolinromeAuthor Commented:
I've already done that before but still same results.

When I go to http://app.domainname.com - I see the Welcome IIS page

When I go to http://app.domainname.com/app/apptest - I see the page I want to see

All I did was add on /app/apptest to the end.
Thanks.
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Can you printscreen the bindings from your 'separated' website?
Maybe also one showing IIS where websites are separated?

I cannot help help but thinking it is directly under default website.
0
 
tolinromeAuthor Commented:
web

bind
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
OK.. In the root directory of your obvious seperated website, is there website code for IIS to work with?
0
 
tolinromeAuthor Commented:
I'm not sure what you mean, please explain? Thanks.
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
If you click your website in IIS and select basic settings.
In the base URL shown there, is there HTML code? (browse to its location and check) E.g. you could copy my code in a index.html and place it there and see what it does.
0
 
tolinromeAuthor Commented:
Patrick, if I click on basic settings I don't see where it leads me to a base url. I see I can select site name or the physical path or connect as or test settings...nothing I see where there is html code or a url.

giveandtake, how do I point to the contents of the application login page and default doc?

Thanks.
0
All Courses

From novice to tech pro — start learning today.