Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 585
  • Last Modified:

WinPE 5 boot error after applying WIM image

I recently created a dual boot (x86/x64) ISO using Windows ADK by following the the instructions on this webpage:

http://www.deploymentresearch.com/Research/tabid/62/EntryId/111/Creating-a-dual-boot-WinPE-5-0-boot-image-x86-and-x64-support.aspx

I then added in several packages and a batch file that allows the user to choose five options, CMD, Startnet, diskpart, gimagex, quit.  This part works great.  Once the environment loads I chose diskpart and ran the following commands:

select disk 0
clean
create part primary
select vol 1
active
assign c:

and then:

format fs=ntfs quick

I then listed the volumes and made sure vol 1 was marked active and had the drive letter "C".  After that I mapped a network drive where the WIM image files are located and launched gimagex.  I chose the source as the network drive share, and the destination as the c:\ drive and clicked apply.  After the image finished applying I rebooted and received this error message:

Windows failed to start.  A recent hardware or software change might be the cause.  To fix the problem:

1.  Insert your Windows installation disc and restart your computer.
2.  Choose your language settings, and then click "Next."
3.  Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer manufacturer for assistance.


Status:  0xc000000e

I'm thinking the issue has something to do with the GUID that I received and placed in the BCD config when creating the x86/x64 wim image files with the link posted above, but I'm not 100% certain.  I searched EE and found something very similar to my issue here:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_26956057.html

Any ideas now I can correct the problem and what may be the cause so I can adjust my WinPE 5.0 setup accordingly?  Thank you very much!


p.s. I sysprepped the image using Win 7 built in sysprep - did not /generalize or /oobe - should I have done that?
0
netfriendsinc
Asked:
netfriendsinc
  • 2
  • 2
1 Solution
 
David Johnson, CD, MVPOwnerCommented:
you have to add the following command
bcdboot c:\windows
0
 
netfriendsincAuthor Commented:
I need to enter that command before creating the ISO image?  Or while in the winPE environment?  Thanks David.
0
 
David Johnson, CD, MVPOwnerCommented:
after you apply the image

imagex /apply .....
bcdboot c:\windows

now you can exit winpe
0
 
netfriendsincAuthor Commented:
thanks that's all that was needed!  much appreciated!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now