Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Unable to copy/paste in RDP from Windows 7 system to 2003 server

Posted on 2014-01-31
4
Medium Priority
?
3,931 Views
Last Modified: 2014-02-24
Greetngs all,

I am logged into a Windows 7 system that is on a domain.  I am hitting a 2003 server via RDP that is not on the domain.  I am logging in as the Local Administrator on the 2003 server.

The server is not a full out Terminal Server (now RDS).

When I remote in I am unable to copy/paste files to the remote server.  The "Paste" option is grayed out when I try and click on it.  I can however, copy/paste raw text to Notepad etc.

I have been all over Google and all I have seen so far is the rdpclip.exe solution that does not work for me.

I have checked the local group policy and nothing is configured.  I already went into my RDP settings on my workstation and made sure "Clipboard" is selected and I even tried going into Local devices and resources and selecting my drives for use during remote session.  Still the "Paste" option is grayed out.

What it seems like to me is that the remote server is not reading or getting the content of my clipboard but I'm not sure why.

This only happens on this single remote server.  All other 2003 and 2008 servers do not have this problem.

Any help would be great...

Thanks.
0
Comment
Question by:yccdadmins
  • 3
4 Comments
 
LVL 3

Expert Comment

by:Ryan Lanham
ID: 39825101
Since you have ruled the issue out using other servers it seems that the Clipboard on the server needs to be restarted.

1. Load up task manager (right click taskbar and select Task Manager)

2. Go to the Processes Tab Select rdpclip.exe

3. Click End Process

4. Go to the Application Tab Click New Process

5. Type rdpclip

6. Click Ok

0
 

Author Comment

by:yccdadmins
ID: 39825120
Sorry Ryan,,,,

"I have been all over Google and all I have seen so far is the rdpclip.exe solution that does not work for me."
0
 

Accepted Solution

by:
yccdadmins earned 0 total points
ID: 39825284
Ok - figured this one out after a little experimentation.

When attempting to remote desktop from my Windows 7 workstation to a Windows 2003 server and copy/paste data files, I was unable to do so.  The Paste option was grayed out.

1 Stopping/starting rdpclip.exe had not worked for me.

2. Next, I expanded the Options in Remote Desktop Connection (RDC) and went to the Local Resources tab.

3. Click the More button and in the Local devices and resources window I selected the drive that my data was stored on.

This did not work either.  I later added all my drives to the selection and copy/paste worked.  I went through the drives one by one and found that along with the drive your data is located on, you need to select the OS drive (Windows (C:) in my case).

So I selected the drive the data was stored on and the C: drive and was able to cut and paste.

Perhaps this is because the content of Clipboard is stored on the C: drive by default.
0
 

Author Closing Comment

by:yccdadmins
ID: 39882036
I selected my own solution because I figured it out on my own.
0

Featured Post

Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

886 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question