Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

IIS Authentication Issue

Posted on 2014-01-31
8
Medium Priority
?
205 Views
Last Modified: 2014-02-06
I have an IIS7 Web site that uses a couple of 3rd party DLL's to genereate barcode images and then renders the page into a PDF, everything works perfectly when I set the site authentication to 'Annonymous'

However, When I set it to 'Windows Authentication' none of the styles/fonts etc.. render properly in the PDF, although the CSS is rendering correctly on other pages in the same site.

I have tried changing the security on the physical directory to full control for everyone (I know, not desired but this is an internal dev server) just to see if that fixes the issue but it does not

Any ideas?
0
Comment
Question by:BrianFord
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 83

Expert Comment

by:David Johnson, CD, MVP
ID: 39826016
Add the app-pool user to the allowed list
0
 
LVL 79

Expert Comment

by:arnold
ID: 39826244
The issue is likely the locations.
i.e. are all the relevant data within the same location or do you have
non-anonymous access site.com/thisdirectory
while the data rendering is in site.com/someotherdirectory
0
 

Author Comment

by:BrianFord
ID: 39826248
All the data is on the same site, the app pool user is an admin with full access to the server

I'm not sure which allow list you mean?
0
What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

 

Author Comment

by:BrianFord
ID: 39826328
I just checked the .NET Authorization Rules and access is allowed for ALL users
0
 
LVL 79

Expert Comment

by:arnold
ID: 39826382
Does access to the entire site require authentication? which options do you have enabled: NTLM/integrated, plain text, digest?

Or do you have auth requirement at a specific point i.e. access to a specific section requires authentication.

One intriguing situation, you're using a .NET application but the authentication you are relegating to the IIS.  Since you are creating a custom web app, why not build into it user authentication as well such that you can then have a more granular control over what resources/functions a user or groups of users can access, etc.

Does your .NET application ever use a HTTP.request object?  Do you have within it a check whether it is "prompted" for authorization by IIS and that is where your issue lies?

i.e. you are using AJAX, JTOn, similar query back to IIS?
0
 

Author Comment

by:BrianFord
ID: 39826823
I have to admit at this point to being totally lost:

I have a Sandbox web site and the Production Web site, both are running on the same server, and both are using the same Application Pool, just different ports and home directories

When I publish to the Sandbox which has both Annon and Windows Auth enabled (the rest are disabled) it works perfectly.

When I publish to production it doesn't work, I have checked all settings for both sites and directory security and unless I'm missing something (which I must be) they both look to be configured exactly the same.

I was considering doing what you suggest and building the security into the pages, which I may end up doing but that would be more work than I really have time for at the moment, although you could argue it would be quicker than trying to resolve this problem but I don't like to beaten :)

I'm using a basic "Request.QueryString" to grab a couple of values from the URL, and I have an HttpHandler defined in the web.config for the 3rd party DLL:

<!-- For Barcode rendering-->
          <handlers>
              <add verb="*" path="BarcodeHandler.aspx" type="Bytescout.BarCode.BarcodeHandler" name="BarcodeHandler"/>
          </handlers>
          
      </system.webServer>
    <system.web>
      
      <!-- For Barcode Rendering -->
      <httpHandlers>
          <add verb="*" path="BarcodeHandler.aspx" type="Bytescout.BarCode.BarcodeHandler, Bytescout.BarCode"/> 
      </httpHandlers>

Open in new window


Other than it's a pretty small basic ASPX site.
0
 
LVL 79

Accepted Solution

by:
arnold earned 1500 total points
ID: 39827228
Double check whether you explicitly set ports that differ on production thus preventing access.
0
 

Author Closing Comment

by:BrianFord
ID: 39839983
Thank you for all your input, I eventually created a whole new site (same server) deployed my app to it and everyting is wotking fine, never really got to teh root issue but at least it's working...... for now :)
0

Featured Post

Plesk WordPress Toolkit

Plesk's WordPress Toolkit allows server administrators, resellers and customers to manage their WordPress instances, enabling a variety of development workflows for WordPress admins of all skill levels, from beginners to pros.

See why 2/3 of Plesk servers use it.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question