Fedora 10, to activate eth0 device on boot automatically.

Hello, everyone, !!

My Fedora 10 setup doesn't activate eth0 network device automatically even I selected at,

eth0
[V]  Activate device when computer starts.

Up to now, I have to [Activate] eth0 manually each time through GUI [Network Configuration]  after bootup.   Is there any good way to make it activate by writing something ?  

such as on

/etc/rc.d/rc.local     file or else

Thanks for your help.  

mkido
mkidoAsked:
Who is Participating?
 
Dan CraciunConnect With a Mentor IT ConsultantCommented:
Please post the output of :
/sbin/chkconfig --list|grep network

Open in new window

0
 
mkidoAuthor Commented:
Well, let me see,
2014-02-01.to-experts.txt
0
 
mkidoAuthor Commented:
[root@biwa ~]# /sbin/chkconfig --list|grep network
error reading info for service net.eth0: No such file or directory
network              0:off      1:off      2:off      3:off      4:off      5:off      6:off
[root@biwa ~]#
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Dan CraciunConnect With a Mentor IT ConsultantCommented:
OK, try these:
# /sbin/chkconfig NetworkManager off
# /sbin/chkconfig network on
# /sbin/service NetworkManager stop
# /sbin/service network restart

Open in new window

Fedora 10 was the first where the network service is disabled by default and they used NetworkManager instead.

HTH,
Dan
0
 
gheistConnect With a Mentor Commented:
1) chkconfig network on
2) echo NETWORKING=yes >> /etc/sysconfig/network
3) echo ONBOOT=yes >> /etc/sysconfig/network-scripts/ifcfg-eth0
0
 
savoneCommented:
Just a side note, Fedora 10 has been end of life for a few years now (almost 4 years).  You should really upgrade to a more modern operating system.

https://fedoraproject.org/wiki/End_of_life
0
 
gheistCommented:
CentOS6 would be closest 1:1 replacement of F10 for today.
0
 
mkidoAuthor Commented:
Hi !   everyone,  Dan Craciun,  gheist,   savone,

Thank you very much of your comments.     I will consider upgrading to Fedora [13,or14,or15] sometime.  

 So before Fedora 10, Network service was the default, after Fedora 10 NetworkManager is getting the default and NetworkManager is taking the main control in newer versions.   Do I understand correctly?     This is due to a new kind of network, WiFi wlan0, right?    


Your scripts sound good.    One moment, I will test them.  


[root@biwa ~]# /sbin/chkconfig --list|grep network
error reading info for service net.eth0: No such file or directory
network              0:off      1:off      2:on      3:on      4:on      5:on      6:off
[root@biwa ~]#


After running one of your scripts, [  2:on      3:on      4:on      5:on  ] appear.   What do they means ?       Bye now.
0
 
Dan CraciunIT ConsultantCommented:
It means the network service will start automatically.
0
 
mkidoAuthor Commented:
Thank you everyone, it worked out all fine.      In the case of  gheist's suggestion, the file netowork got appended, NETWORKING=yes; AND  the file /ifcfg-eth0 got appended ONBOOT=yes.    

They made the network service start automatically.
0
 
gheistCommented:
You can use CentOS to run whatever you run on Fedora 10 and be secure and modern for today....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.