Exchange 2003 Email Forwarding to External

Hi,

For 500 points can someone provide a solution to the issue I have.  

I have an Exchange 2003  SP2 Server that is configured to route outgoing external email via a smart host (SMTP2Go) which works fine until I try to place a forward on an internal account to an external email provider.

Example:-

Fred has an Exchange email account fred@mydomain.com and wishes all his email to be placed on forward (copy left in local Exchange) to fred@gmail.com

I've created a contact called "fred external" with an email address of fred@gmail.com and placed a forward in AD Exchange on fred@mydomain.com to "fred external" which results in NDR's as below.

There was an SMTP communication problem with the recipient's email server
<mail.mydomain.com #5.5.0 smtp:550 relay refused fred@gmail.com/external IP of Exchange by this user>

SMTP2Go allows external processing of mydomain.com emails and we have no issues sending a new email to fred@gmail.com - just cannot do this using a forward.

I realise this might be seen as relaying (our Exchange server is secure) however there must be a way for the system to allow forwarding of emails from internal to external.

Can anyone help?

Thanks
Wayneinuk
wayneinukAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
This is a problem with SMTP2Go, and there probably isn't a way round.
When you forward using a contact, the header information stays the same. This means it looks like your server is spoofing the original sender's domain. If the sender's domain has implemented anti-spoofing techniques, which GMAIL has and the next server is using it, then the email will be blocked.
I don't know how SMTP2Go controls the use of their relay, but if it is by domain name, then you are stuffed, because you would have to list every domain name that could send email to you and be forwarded - which simply isn't going to happen.

Simon.
0
 
Michael OrtegaConnect With a Mentor Sales & Systems EngineerCommented:
As a test only, can you setup a 2nd smtp connector to send email out scoped only to gmail.com? Make sure to not send out via smarthost, but by the default DNS option. I realize that you might not have a PTR record in place for the public IP your Exchange server sits behind which might mean that the gmail servers reject the email, but if they do reject the email that means that the email is actually getting to gmail. That would tell you that the outbound relay is the problem and to contact that service for assistance.

MO
0
 
hecgomrecCommented:
Ok this is what you should do....


Remove the forward from the user account.
Delete the contact you created.
Create the contact again without creating an Exchange Mailbox
Edit the properties of the account and in the general tab write the email of the contact.
Now right click the contact and select Exchange tasks... and create a mailbox
Select again the properties of the contact and edit the Exchange Advanced tab to Hide from Exchange address list;  In the E-mail Address Tab, make sure the address is correct; only the gmail address should be set as the default.  ex.:SMTP:testers@gmail.com
Enable the forward on the user's account and select to deliver the message to both.

Now you should be able to send without errors.
0
 
wayneinukAuthor Commented:
Hi,

I'd considered MO's suggestion however taking into account what Simon had commented on I went back to the SMTP2Go console and added the specific email addresses that I wanted to allow forwarding to as the Restricted tab allows you to specific email addresses as well as domains.

I have awarded points as per the solution provided i.e. Simon's advice led to the resolution / MO's advice was useful as well.

Thanks both for your assistance.

Wayne
0
 
wayneinukAuthor Commented:
Hi,

Just noticed a post from hecgomrec as well - I'd already done this with no luck unfortunately - SMTP2Go was preventing the relay as suggested by Simon.

Thanks
0
All Courses

From novice to tech pro — start learning today.