server 2008 R2, no internet until repeatedly clearing DNS cache

I am a beginner administrator for my own Win 2008 R2 server.  In the last 2 weeks, I noticed that the workstations internet access has gotten slower and sometimes does not connect to the net.  It also got slower trying to connect to the server via RDP and Outlook Web Access.  Now, it has gotten so bad that there is no access, except for every couple of hours I can get some very slow access to the net.

I tried clearing the DNS cache and it works (back to normal speed) for maybe an hour.  Then it's back to supper slow or no internet.  The speed of our LAN seems normal.  The ISP has done testing and says it's not on their side.

Please help a beginner.
ken_bAsked:
Who is Participating?
 
Michael OrtegaConnect With a Mentor Sales & Systems EngineerCommented:
First thing to check is go to a client computer and statically set the primary DNS as 8.8.8.8. See what your browsing experience is like. Make sure to flushdns cache on the computer first.

If browsing is just fine then the issue is with DNS between the client and server or with the public DNS forward that your server is using.

You can check the forwarder by going into the DNS MMC, right clicking the server node and going into properties. Check the forwarders tab. Is there anything in there? If not, add 8.8.8.8 and apply. See if that helps. If there is anything in there try to remove it and try 8.8.8.8.

If you have problems with the client machine using static DNS of 8.8.8.8 then there might be a network related issue. Try and simply ping 8.8.8.8 continuously looking for any significant variability in your packet transmission, e.g. packet loss or high latency.

MO
0
 
Michael OrtegaSales & Systems EngineerCommented:
Are you using DNS forwarders on your DNS/AD servers? You might check those. I'd recommend using something like google DNS (8.8.8.8).

MO
0
 
KorbusCommented:
Are your workstations using your server for DNS? (Assuming you have DNS installed on your server, they should be.)  What do they have configured for secondary DNS?  Is it on the workstations that you clear the DNS cashe (or the server)?

In addition to checking the forwarder setting in the DNS server, as mgortega suggested, I recommend you also confirm the server is configured to use itself for DNS, and does not have a secondary DNS configured.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
ken_bAuthor Commented:
Thanks for the input.

So, I do not believe that I am forwarding in the DNS server.  How would I confirm this?

I checked my DHCP settings in the admin- DHCP area, and under DNS it showed that the first position address was the server.  I changed that to 8.8.8.8 as an experiment, but it did not seem to help.  Is there another place to check/change the Dns settings, like in the admin for the DNS?

When I said that I did a DNS cache clear, I meant that I did it on the server.  The workstations are dynamic for the DNS.
0
 
kostbadConnect With a Mentor Commented:
Go to server manager - > tools-> DNS.

Right click on your server-> properties.

The ip shown in "interfaces" should be set on your client pc's.
You can also check your logs for dns errors.

Personally i use forwarders to point to opendns, but that's not necessary, although it helps in many circumstances (blocks blacklisted ip's-viruses).
0
 
ken_bAuthor Commented:
Ok, I am actively working this issue, but may be abit slow to respond because I am on my cell phone due to the server net problems.

I looked in the DNS manager console and then to properties and forwarders tab.

My ISP DNS were listed there and so I have added 8.8.8.8 and moved to the top of the list.  Then applied.  Is there anything else to do before I test again?
0
 
ken_bAuthor Commented:
Problem still here, but I did run the best practice scan on DNS in the server manager and here is the result:

Warning scavenging should be enabled

Warning local area connection has only preferred DNS configured, add another to the adapter

Error, network adapter doesn't list a loop back IP address as a DNS server

I would like to correct this but am lost especially on the last one
0
 
KorbusCommented:
>>Error, network adapter doesn't list a loop back IP address as a DNS server

This means it wants your server's NIC's DNS config to point at the server itself.  (the setting you see when you run ipconfig)  What is you ipconfig on the server now?
0
 
ken_bAuthor Commented:
The server ipconfig shows the server fixed up address under DNS.

Isn't the best practice error try to have me put the ISP or 8.8.8.8 into first positio on the nic card DNS and the server ip "loop back" into 2nd?
0
 
ken_bAuthor Commented:
Got rid of the scavenging warning by enabling it with default setting of 7 days

Still not able to get rid of loop back notice
0
 
kostbadCommented:
The way you describe it, the dns settings seem to be ok and not the cause of the problem.

It could also be a router problem. Have you done any changes there?
0
 
ken_bAuthor Commented:
I bought a new one after the problem started and installed it, with no change.

After last changes above web access problem is gone for now.  Will report back in a few hours with status.  Fingers crossed for now
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.