Personal.xlsb code modules all opening every time I open the VBA Editor

Hi Experts

I have just upgraded from XP to Windows 8.1 and now in Excel 2007, every time I open the VBA Editor, all the code modules from my personal.xlsb are open.
This behaviour never happened in XP so I am guessing it is possible to "switch off".

I have my personal.xlsb in the XLStart folder as I did in XP.

I do want it available, but not all the code windows opening.

Thanks in advance

Nick
LVL 13
Nick DennyAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Nick DennyConnect With a Mentor Author Commented:
Thanks Rory. I tried your suggestion but all windows are still open when restarting Excel.
However, as said, a simple click to collapse gets rid when they are not wanted.

Is it actually possible to start the VBE with the all projects collapsed?

I have tried starting Excel with a blank workbook, no workbook (the  /e option), and direct through file association.

All results are the same for me.

Thanks

Nick
0
 
MacroShadowCommented:
1. Open personal.xlsb
2. View tab >> Hide >> Select personal.xlsb
3. Exit Excel, save if prompted
0
 
Nick DennyAuthor Commented:
Thanks for response.
Personal.xlsb is already hidden.
My challenge is when I open the VBE (Alt+F11) the code windows are all open.
I would prefer them all to be closed.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
MINDSUPERBCommented:
Have you tried closing them one by one? Then, open again the VBE?

Sincerely,

Ed
0
 
Nick DennyAuthor Commented:
Thanks Ed, yes I tried that and they still all remain open.

However, unless there is some way of doing this natively, I am using the "hide windows when collapsing the project" option in the tools menu.

This will do I suppose as its only a click of the mouse.

Thanks again.

I will leave a while in case there is an option somewhere.
0
 
Rob HensonConnect With a Mentor Finance AnalystCommented:
Might seem a daft question but after closing the windows in the VBE, are you saving the file?

Thanks
Rob H
0
 
Nick DennyAuthor Commented:
I am clicking the "save" icon  in the VBE and it is still displaying the same when I reopen Excel.
When I first posted, the tiles were randomly all over the VBE, now for some reason at least they are neatly stacked????

It seems I am having a few issues with Excel, so this may be a reinstall job.

Another q:
http://www.experts-exchange.com/Software/Office_Productivity/Office_Suites/MS_Office/Excel/Q_28354903.html

Thanks
0
 
Rory ArchibaldConnect With a Mentor Commented:
Clicking Save in the VBE is flaky at best. Once you have collapsed the project, use:
Workbooks("Personal.xlsb").Save

Open in new window

in the Immediate window.
0
 
Rory ArchibaldCommented:
Strange - that method works for me.
0
 
Nick DennyAuthor Commented:
Thanks for all input.
Things seem to have settled down so long as I collapse the Personal project.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.