Solved

NAt + OSPF

Posted on 2014-02-03
3
1,380 Views
Last Modified: 2014-02-05
HI guys
I have this scenario in GNS3 it is purely lab scenario connection to internet :I have R2 bridge to  internet from R2 I can ping any address on internet the same goes for R1 but I cannot ping any internet addresses  or 172.16.1.2 I run ospf and I like to have multiple subnets of different networks behind NAT to be able to access internet . what do I missing  I try static address and so on but nothing worked .How would it be done .IS there such set in real life that you get multiple networks behind one NAT perhaps office or so from different class of network .How is ofps work with NAT. and if I would add vpn how all this will be configured? Thanks very much.

R2 Router
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 ip nat inside

interface FastEthernet0/1
 ip address 192.168.1.25 255.255.255.0
 ip nat outside
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip nat pool nat 192.168.1.25 192.168.1.25 netmask 255.255.255.0
ip nat inside source list 1 pool nat overload
access-list 1 permit 172.16.0.0 0.0.7.255


router R1
interface FastEthernet0/0
 ip address 172.16.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 5.5.5.1 255.255.255.0
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
 network 2.2.2.0 0.0.0.255 area 0
 network 5.5.5.0 0.0.0.255 area 1
 network 172.16.1.0 0.0.0.255 area 0
 network 0.0.0.0 255.255.255.255 area 0
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1


R5 router
interface Loopback1
 ip address 7.7.7.7 255.255.255.0
interface FastEthernet0/0
 ip address 6.6.6.6 255.255.255.0
interface FastEthernet0/1
 ip address 5.5.5.5 255.255.255.0
router ospf 1
 network 5.5.5.0 0.0.0.255 area 1
 network 6.6.6.0 0.0.0.255 area 1
 network 7.7.7.0 0.0.0.255 area 1

see bellow config and picture :
GNS--NAT.docx
0
Comment
Question by:homolama
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 6

Assisted Solution

by:Jordan Medlen
Jordan Medlen earned 500 total points
ID: 39829534
Unless you've omitted it, I do not see OSPF configured on R2. Can you do "sh ip ospf neighbor" on R2 and R1 and provide the output here?
0
 

Author Comment

by:homolama
ID: 39829901
no sure it is not there just a static route which is redistributed in R1. i have ospf on router R2 before but it did not work so i try this way with no ospf .If you know how to just let me know .Thanks
0
 
LVL 6

Accepted Solution

by:
Jordan Medlen earned 500 total points
ID: 39829911
Based on your configurations, there is no way for R2 to know where to send traffic for any other subnet on your internal LAN, as it's default gw points externally. So traffic for the 1.1.1.0, 2.2.2.0, etc subnets will be dropped.
0

Featured Post

Register Today - IoT Current and Future Threats

Are you prepared to protect your organization from current and future IoT Threats?  Join our Wi-Fi expert in episode three of our webinar series for a look at the current state of Wi-Fi IoT and what may lie ahead. Register for our live webinar on April 20th at 9 am PDT!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
creating SVI on layer 3 switch 1 51
FTP server backups 5 42
BGP Local Preference 5 45
Cisco 4400 will not take SFP module ? SFP 10 GB module 1 44
Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question