Solved

Exchange 2013 increase allowed mobile devices per email account

Posted on 2014-02-03
6
1,602 Views
Last Modified: 2014-02-05
We need to allow 30 mobile devices per email account in Exchange 2013, what is the easiest way of doing so? This needs to be implemented for current accounts as well as future accounts.
0
Comment
Question by:jhuntin
  • 3
  • 3
6 Comments
 
LVL 36

Expert Comment

by:Jian An Lim
ID: 39831846
http://www.msexchange.org/kbase/ExchangeServerTips/ExchangeServer2010/Mobility/HowtoincreasethemaximumnumberofActiveSyncDevicesforaUser.html

default it allows 10

so you need to change the default throttling policy

get-throttlingpolicy | set-throttlingpolicy -EasMaxDevices 30 -EasMaxConcurrency 30


this will applies to every existing and new account as long as they have default throttling policy.
0
 

Author Comment

by:jhuntin
ID: 39836349
I run the following command and the get the following:


[PS] C:\Windows\system32>get-throttlingpolicy | set-throttlingpolicy -EasMaxDevices 30 -EasMaxConcurrency 30
The global throttling policy is read-only. Create a new organization throttling policy instead.
    + CategoryInfo          : InvalidOperation: (GlobalThrottlin...c9-fdc704715c77:ADObjectId) [Set-ThrottlingPolicy],
    LocalizedException
    + FullyQualifiedErrorId : 2F58CAEB,Microsoft.Exchange.Management.SystemConfigurationTasks.SetThrottlingPolicy
    + PSComputerName        : servicesupply.serviceplussupply.local

[PS] C:\Windows\system32>
0
 

Author Comment

by:jhuntin
ID: 39836464
On another note I created a new policy but when I go to assign it to a user it is not in the list although the command completed correctly.Screen Shot
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 36

Accepted Solution

by:
Jian An Lim earned 500 total points
ID: 39837046
the assigned of SUCH policy is not a mobile device policy but throttling policy for the mailbox

So since you can't edit the global

 try below

New-Throttlingpolicy "Increased ActiveSync Devices" -EasMaxDevices 30 -EasMaxConcurrency 30              


for single user
Set-Mailbox <user> -ThrottlingPolicy "Increased ActiveSync Devices"

for the whole organisation
get-mailbox -resultsize unlimited | Set-Mailbox -ThrottlingPolicy "Increased ActiveSync Devices"

For future,

you can change your new policy to the default policy

Set-Throttlingpolicy "Increased ActiveSync Devices" -isdefault:$true

**hint**: if you want to change the default, i will suggest you look at all settings and make sure you keep the settings as much as you can.
0
 

Author Comment

by:jhuntin
ID: 39837172
Thanks but I get the following error when trying to make it defauly:


[PS] C:\Windows\system32>Set-Throttlingpolicy "Increased ActiveSync Devices" -isdefault:$true
A parameter cannot be found that matches parameter name 'isdefault'.
    + CategoryInfo          : InvalidArgument: (:) [Set-ThrottlingPolicy], ParameterBindingException
    + FullyQualifiedErrorId : NamedParameterNotFound,Set-ThrottlingPolicy
   

Also I see the new policy is there with the get command:

[PS] C:\Windows\system32>get-throttlingpolicy

Name                                    ThrottlingPolicyScope                   IsServiceAccount
----                                    ---------------------                   ----------------
GlobalThrottlingPolicy_65c30886-1aad... Global                                  False
Increased ActiveSync Devices            Regular                                 False

But when I use the comannd :
get-mailbox -resultsize unlimited | Set-Mailbox -ThrottlingPolicy "Increased ActiveSync Devices"

I get that it wasnt applied for every mailbox it goes through, also in the ECP I dont not see that policy to apply it to each mailbox all I see is the default am I missing something?
0
 
LVL 36

Expert Comment

by:Jian An Lim
ID: 39837266
Set-Throttlingpolicy "Increased ActiveSync Devices" -isdefault:$true will not work sadly.


this means everytime you create a newmailbox, you need to change the throttling policy for each user.

#############

this do not work in ECP that i believe.
This is a throttling policy

#################

Get-ThrottlingPolicy | fl identity,is*
it shows you the default

get-mailbox -resultsize unlimited | FT identity, *Throttling*
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

As with any other System Center product, the installation for the Authoring Tool can be quite a pain sometimes. This article serves to help you avoid making these mistakes and hopefully save you a ton of time on troubleshooting :)  Step 1: Make sur…
We were having a lot of "Heartbeat Alerts" in our SCOM environment, now "Heartbeat" in a SCOM environment for those of you who might not be familiar with SCOM is a packet of data sent from the agent to the management server on a regular basis, basic…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
The view will learn how to download and install SIMTOOLS and FORMLIST into Excel, how to use SIMTOOLS to generate a Monte Carlo simulation of 30 sales calls, and how to calculate the conditional probability based on the results of the Monte Carlo …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now