Eclipse error on the Google App Engine web application

Posted on 2014-02-03
Medium Priority
Last Modified: 2014-02-14
I am trying to run the guestbook application https://developers.google.com/appengine/docs/java/gettingstarted/creating but getting error:

I tried it on Eclipse with the recent version. In Eclipse I click Run menu and then "Debug As"->"Web application". The error popup shows as attached.
Could you please suggest how to fix. Thank you.
Question by:toooki
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
LVL 12

Expert Comment

by:Sharon Seth
ID: 39831877
Which web server are you using ? The error mostly points out that the server is not started in debug mode . Run it in normal mode and see

Author Comment

ID: 39832703
If I run it via "Run"->"Run As"->"Web Application", I get the following error. I have IIS server installed on the pc.

Feb 04, 2014 9:21:16 AM com.google.apphosting.utils.config.AppEngineWebXmlReader readAppEngineWebXml
INFO: Successfully processed C:\Users\workspace\Guestbook\war\WEB-INF/appengine-web.xml
Feb 04, 2014 9:21:16 AM com.google.apphosting.utils.config.AbstractConfigXmlReader readConfigXml
INFO: Successfully processed C:\Users\workspace\Guestbook\war\WEB-INF/web.xml
Feb 04, 2014 9:21:16 AM com.google.appengine.tools.development.SystemPropertiesManager setSystemProperties
INFO: Overwriting system property key 'java.util.logging.config.file', value 'C:\Users\Downloads\eclipse-jee-kepler-SR1-win32-x86_64\eclipse\plugins\com.google.appengine.eclipse.sdkbundle_1.8.9\appengine-java-sdk-1.8.9\config\sdk\logging.properties' with value 'WEB-INF/logging.properties' from 'C:\Users\workspace\Guestbook\war\WEB-INF\appengine-web.xml'
Feb 04, 2014 9:21:17 AM com.google.apphosting.utils.jetty.JettyLogger info
INFO: Logging to JettyLogger(null) via com.google.apphosting.utils.jetty.JettyLogger
Feb 04, 2014 9:21:18 AM com.google.apphosting.utils.jetty.JettyLogger info
INFO: jetty-6.1.x
Feb 04, 2014 9:21:44 AM com.google.apphosting.utils.jetty.JettyLogger warn
WARNING: failed org.mortbay.jetty.nio.SelectChannelConnector$1@5a41ca05: java.io.IOException: Unable to establish loopback connection
Feb 04, 2014 9:21:44 AM com.google.apphosting.utils.jetty.JettyLogger warn
WARNING: failed SelectChannelConnector@ java.io.IOException: Unable to establish loopback connection
Feb 04, 2014 9:21:44 AM com.google.apphosting.utils.jetty.JettyLogger warn
WARNING: failed Server@1d192738: java.io.IOException: Unable to establish loopback connection
java.io.IOException: Unable to establish loopback connection
      at sun.nio.ch.PipeImpl$Initializer.run(Unknown Source)
      at sun.nio.ch.PipeImpl$Initializer.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at sun.nio.ch.PipeImpl.<init>(Unknown Source)
      at sun.nio.ch.SelectorProviderImpl.openPipe(Unknown Source)
      at java.nio.channels.Pipe.open(Unknown Source)
      at sun.nio.ch.WindowsSelectorImpl.<init>(Unknown Source)
      at sun.nio.ch.WindowsSelectorProvider.openSelector(Unknown Source)
      at java.nio.channels.Selector.open(Unknown Source)
      at org.mortbay.io.nio.SelectorManager$SelectSet.<init>(SelectorManager.java:312)
      at org.mortbay.io.nio.SelectorManager.doStart(SelectorManager.java:223)
      at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
      at org.mortbay.jetty.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:314)
      at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
      at org.mortbay.jetty.Server.doStart(Server.java:235)
      at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
      at com.google.appengine.tools.development.JettyContainerService.startContainer(JettyContainerService.java:250)
      at com.google.appengine.tools.development.AbstractContainerService.startup(AbstractContainerService.java:306)
      at com.google.appengine.tools.development.AutomaticInstanceHolder.startUp(AutomaticInstanceHolder.java:26)
      at com.google.appengine.tools.development.AbstractModule.startup(AbstractModule.java:79)
      at com.google.appengine.tools.development.Modules.startup(Modules.java:97)
      at com.google.appengine.tools.development.DevAppServerImpl.doStart(DevAppServerImpl.java:255)
      at com.google.appengine.tools.development.DevAppServerImpl.access$000(DevAppServerImpl.java:47)
      at com.google.appengine.tools.development.DevAppServerImpl$1.run(DevAppServerImpl.java:213)
      at com.google.appengine.tools.development.DevAppServerImpl$1.run(DevAppServerImpl.java:211)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.google.appengine.tools.development.DevAppServerImpl.start(DevAppServerImpl.java:211)
      at com.google.appengine.tools.development.DevAppServerMain$StartAction.apply(DevAppServerMain.java:277)
      at com.google.appengine.tools.util.Parser$ParseResult.applyArgs(Parser.java:48)
      at com.google.appengine.tools.development.DevAppServerMain.run(DevAppServerMain.java:219)
      at com.google.appengine.tools.development.DevAppServerMain.main(DevAppServerMain.java:210)
Caused by: java.net.ConnectException: Connection timed out: connect
      at sun.nio.ch.Net.connect0(Native Method)
      at sun.nio.ch.Net.connect(Unknown Source)
      at sun.nio.ch.Net.connect(Unknown Source)
      at sun.nio.ch.SocketChannelImpl.connect(Unknown Source)
      at java.nio.channels.SocketChannel.open(Unknown Source)
      ... 31 more
LVL 12

Accepted Solution

Sharon Seth earned 2000 total points
ID: 39834932
Is this port open on your machine when the app is running - 8891? It is not getting a connection on that port on your PC

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re thinking to yourself “That description sounds a lot like two people doing the work that one could accomplish,” you’re not alone.
In this post we will learn how to connect and configure Android Device (Smartphone etc.) with Android Studio. After that we will run a simple Hello World Program.
The viewer will learn how to implement Singleton Design Pattern in Java.
This tutorial will introduce the viewer to VisualVM for the Java platform application. This video explains an example program and covers the Overview, Monitor, and Heap Dump tabs.
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question