Solved

Unable to launch Citrix Xenapp 6.0 Desktop

Posted on 2014-02-03
41
1,552 Views
Last Modified: 2014-02-11
Hi Experts,

I have a Citrix Xenapp server that I configured but I am not able to launch the desktop.

I am able to authenticate fine and is able to see the Citrix-Desktop Icon but when I click on the Desktop icon to launch the desktop, I am getting these error messages:

1 -  Your client platform is not supported by this Web site. Contact your system administrator.

2- Unable to launch your application. Contact the help desk with the following information:

Cannot connect to the Citrix XenApp server. There is no Citrix XenApp server configured on the specified address.

Any idea how I can resolve this error messages ?

Thanks
0
Comment
Question by:Teavana
  • 25
  • 9
  • 7
41 Comments
 
LVL 24

Expert Comment

by:Sekar Chinnakannu
ID: 39831451
try to telnet <server ip> 1494, make sure you have a proper route has been configured. also http://discussions.citrix.com/topic/345082-there-is-no-citrix-xenapp-server-configured-on-the-specified-address/
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831580
Thank you, I will try this now and report back.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831606
I got ICAICA .....
0
 
LVL 24

Expert Comment

by:Sekar Chinnakannu
ID: 39831611
can you check and make sure all the services are in running state, if possible reboot the server and check.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831628
I will reboot the server now. I notice that there is no XML service under services.

Any thoughts
0
 
LVL 24

Expert Comment

by:Sekar Chinnakannu
ID: 39831634
is this server act as data collector role? if not then no worries.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831643
I would say yes, this is the only server in the farm.
0
 
LVL 24

Expert Comment

by:Sekar Chinnakannu
ID: 39831647
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831666
Thanks, I will register the port.

Should I use port 80 or 8080 for the port. I read some where that the port must be share with IIS.
0
 
LVL 24

Expert Comment

by:Sekar Chinnakannu
ID: 39831671
it depends on you, I prefer to go for 8080
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831680
OK, that is what I am doing now, thanks
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831693
Thanks, we were able to resolve item 1 but I am now getting this messages:

Unable to launch your application. Contact the help desk with the following information:

Cannot connect to the Citrix XenApp server. There is no Citrix XenApp server configured on the specified address.

Any thoughts
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831702
Do you think a hot fix will fix this issue, I do not have any hotfixes installed.

I am running xenapp 6.0
0
 
LVL 24

Expert Comment

by:Sekar Chinnakannu
ID: 39831706
change IMA\XTE service to run as local account from network account. Make sure to grant full access to IMS folder under C drive. also try to recreate the lhc http://support.citrix.com/article/CTX759510
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831711
I get this error message when I try to install the hotfix
0
 
LVL 24

Expert Comment

by:Sekar Chinnakannu
ID: 39831716
which one you trying try to install roll up pack 2 http://support.citrix.com/article/CTX133882
what error you are getting
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831722
Taking these steps now
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831725
I see the  XTE server service but no IMA service
0
 
LVL 1

Author Comment

by:Teavana
ID: 39831746
Your link for the hotfix is working, I was getting the attached error message before
error1.png
0
 
LVL 1

Author Comment

by:Teavana
ID: 39832182
Did all the suggested steps but the issue is the same :-(
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 39832205
The IMA Service should run (full Name: Citrix Independent Management Architecture)
is the client within the same subnet as the server?
is there some accesslist/firewall between them?
is the server-firewall configured correctly? Try to disable the server firewall temporary.
is the a virusscan/endpoint-security installed (McAffee / Symantec / ...) the can block packets also.
try to catch the launch.ica and check the contend (or post them here).
0
 
LVL 1

Author Comment

by:Teavana
ID: 39832243
I am trying to access the server remotely and from the same subnet.

I check the event log and I notice that I was getting an error message the Citrix ICA listener was disable.

If found an article that says this KB2653956 caused the listener to go off-line.

I un-installed the KB, rebooted the server and now when I try to run an discovery process it fails.
.
do now I cannot not log into the server from citrix client
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 39832293
if you reach port 1494 (ICAICAICA...) the ica listener is up.
if you change the CTX-XML-Port (ctxxmlss) you have to make this changes within the web interface configuration also.
are you able to see the app-list within the webinterface or other client?
0
 
LVL 1

Author Comment

by:Teavana
ID: 39832431
I can reach the port 1494,
I changed the CTX-XML web interface and command line.

I am not able to see the App-list with the web interface or the client.

Should I just blow this server away and start over ?
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 39832442
rebuilding the server is an option ... sure.

are you able to logon to the webinterface ... or what error is displayed.
with WI errors you should see messages within the eventlog.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39832462
I was not able to log into the web interface and I could get the app-list to during the discovery process it failed.

I am in the process of wiping the VM and starting over now.

Any thing I should watch out for ? Thanks
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 39832497
no, should be simple ...
I would suggest install all from the xenapp cd with the installer provided.
install newer versions (possible WI) late.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39832514
for remote desktop services, should I installed this separately  or from the xenapp installer.

Also, should I do the ISS integration option or No

Thank you again for all your help, I really appreciate it.
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 39832527
i allways use the installer for RD services and IIS integration.
if you use the IIS at this server you should also select "integrate with IIS" ... also if you choose to change the XML Port later.
if you need the WebInterface at this server, you need the IIS.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39832571
Thank you, I will follow your recommendations. I will update you as soon as I finish install the Xenapp part.

The OS is done, just doing updates.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39833387
I am getting the same error message again.

Unable to launch your application. Contact the help desk with the following information:

Cannot connect to the Citrix XenApp server. There is no Citrix XenApp server configured on the specified address.

The web interface tries to launch and then times out.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39833620
Update,

I am able to connect internally via the web interface but when I try to login remotely, I am able to authenticate but the web interface times out.

Any thoughts
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 39834943
you see the apps, but if you try to start the app you get the time-out... right?
do you using NAT?
you have different websites for internal and external access?
catch the launch.ica file. The content mostly gives you a hint.
to get the launch.ica use a pc without citrix-client installed or a browser with high security settings (prompts for "save file")
0
 
LVL 1

Author Comment

by:Teavana
ID: 39835751
you see the apps, but if you try to start the app you get the time-out... right?  Correct

do you using NAT?  Yes

you have different websites for internal and external access?

I am using the internal IP inside and  a public IP from Out side (NAT)

catch the launch.ica file. The content mostly gives you a hint.
to get the launch.ica use a pc without citrix-client installed or a browser with high security settings (prompts for "save file")   I will try this option.

I was able to get the out-side access to work by performing the following command.

ALTADDR /set x.x.x.x (where x.x.x.x is the alternate external IP address of the XenApp server)

Are you aware of this command function ?

If yes, can you help me to understand the function ?

Thanks
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 39835773
the altaddr command is to set an additional alternate address at the server.
without this address the launch.ica file contains "please contact me by my real (internal) IP".
This can't work, because this ip is not reachable from outside mostly.
with altaddr set this IP is written to the launch.ica also. so the client is able to find the server.
0
 
LVL 23

Expert Comment

by:Dirk Kotte
ID: 39835784
if you place a CitricSecureGateway behind the NAT boarder (within the DMZ or LAN) the client connects to this CSG with SSL (TCP443) ... for app-enumeration and session initiation.
Here the CSG relays the data to the server(s) and you don't need ALTADDR.
0
 
LVL 1

Accepted Solution

by:
Teavana earned 0 total points
ID: 39837931
Hi Dkotte,

Thank you for this information. One last question ....

When I installed the xenapp software, I only selected the following roles:
- XenApp
- Web Interface

I did not select the Citrix Secure Gateway (CSG) option. should I have installed this role ?

How can I check to see what roles are installed on the XenApp machine (apart from checking the installed programs in control panel).

The reason why I am asking is ..... I installed a stand alone citrix server a few months back and I was able to access this server remotely and I do not remember configuring a CSG, just the web interface.

This was my first Citrix installation in an AD environment.... just wondering if the two are related in anyway.

Thanks
0
 
LVL 23

Assisted Solution

by:Dirk Kotte
Dirk Kotte earned 500 total points
ID: 39838206
you can run the Citrix server with Webinterface only (with altaddr and NAT). But you should not.
Without SSL your traffic ist not really good encrypted.
CSG is a good way to secure the traffic. within a single server installation I have the CSG at the same server installed.
With CSG the traffic is more secure, the config is more simple (no NAT), ...

Which components are installed you see at the managementconsoles...
AppCenter for XenApp, WI-Console and CSG console ... but best within installed programs in control panel.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39838991
Thank you for your help and recommendations, I appreciate it.
0
 
LVL 1

Author Comment

by:Teavana
ID: 39839008
dkotte's recommendation is the solution.
0
 
LVL 1

Author Closing Comment

by:Teavana
ID: 39849649
Thank you
0

Featured Post

The curse of the end user strikes again      

You’ve updated all your end user’s email signatures. Hooray! But guess what? They’re playing around with the HTML, adding stupid taglines and ruining the imagery. Find out how you can save your signatures from end users today.

Join & Write a Comment

New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now