Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1559
  • Last Modified:

Invisible blinking text cursor using HP thin client

We have a Server 2008 R2 virtual machine hosted on VMware ESXi 5.5.0, running as a Remote Desktop server with the desktop experience feature installed, and Office 2010.  Windows and Office are up-to-date with patches from Microsoft Update.

When connecting from a Windows computer to the server using RDP, everything works fine.  When connecting using an HP thin client (t510, latest OS build - ZX644017), the blinking text cursor in Word 2010 and Outlook 2010 cannot be seen.  The mouse cursor shows up fine.

Settings made in the Ease of Access Center (thickness of the blinking cursor) and other cursor settings (mouse pointer scheme and options) make no difference.

I have attempted to replicate the problem on a similar system but have been unable to (everything works fine).

How can I make sure the text cursor is displayed at all times when using the HP t510 thin client?

Thanks in advance for any tips!
0
David Haycox
Asked:
David Haycox
  • 4
  • 2
1 Solution
 
David HaycoxAuthor Commented:
We have just discovered that if you log on as a local or domain administrator, there is no problem.  It's only regular (non-admin) users who are affected.

So does that point at a setting on the server, rather than anything on the thin client (although logging on as a standard user by RDP from a PC is still fine)?
0
 
CoralonCommented:
I'd guess there is probably a GPO setting that is setting the registry value for HKCU\Control Panel\Desktop\CursorBlinkRate.  If you set it very high or to 0, it will appear to not blink (or really won't blink at all).

Use your gpresults to find out if it is being set, or use the GPMC Results wizard to see if it is being set.

Coralon
0
 
David HaycoxAuthor Commented:
Thanks, sounds promising... but after checking I can confirm there are no group policies affecting that.  Setting the rate manually, then running GPUPDATE before logging off and back on again does not change the setting back.

The problem isn't that the cursor doesn't blink - it's that it can't be seen at all.

I have checked the registry for various users; the CursorBlinkRate is set to 530 for most users (which I believe is the default) but others have it set to -1 (do not blink).

Any other ideas?  Thanks again!
0
2017 Webroot Threat Report

MSPs: Get the facts you need to protect your clients.
The 2017 Webroot Threat Report provides a uniquely insightful global view into the analysis and discoveries made by the Webroot® Threat Intelligence Platform to provide insights on key trends and risks as seen by our users.

 
CoralonCommented:
Yeah.. 530 is the default for Win7.   Unless the pointer's theme is getting messed up (obviously that is seriously unlikely).. I have no idea..

Coralon
0
 
David HaycoxAuthor Commented:
We resolved the problem by disabling the Themes service, thereby also disabling Aero.  Manually disabling it from each user session would also have worked.
0
 
David HaycoxAuthor Commented:
Solved problem myself.
0

Featured Post

Put Machine Learning to Work--Protect Your Clients

Machine learning means Smarter Cybersecurity™ Solutions.
As technology continues to advance, managing and analyzing massive data sets just can’t be accomplished by humans alone. It requires huge amounts of memory and storage, as well as the high-speed power of the cloud.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now