Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2010 Emails not synchronizing on shared mailbox

Posted on 2014-02-04
9
Medium Priority
?
2,681 Views
Last Modified: 2014-02-10
We have multiple users that have full and send as permissions to another mailbox in our organization. All users use "Cached Exchange Mode". For some reason these users are no longer able to see new email as it arrives in the shared mailbox; but they can see mail in their own mailbox. When I delete and re-create the user's mailbox profile; the mail is seen again. Is there a way to correct this issue without having to take the user out of cached exchange mode? This is happening to users with Outlook 2010 and 2013.

Does this have something to do with Exchange 2010's throttling settings?
0
Comment
Question by:nti1999
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
9 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39833022
Are you adding the shared mailbox as an additional MAILBOX or an additional ACCOUNT?

If you are doing the former, do the latter (using the New Account wizard). It changes the way that Outlook 2010 and higher connects to Exchange. Plus it gives notifications and rules access to the Shared mailbox.

How many users are accessing the mailbox? Throttling could be the problem.

Simon.
0
 
LVL 23

Expert Comment

by:Patrick Bogers
ID: 39833037
Hi

Check the server event logs if it states something like 'exceeded the maximum number of object (folderview) in event (i believe 9646)

If yes you should fix this by raising the limit in registry or delete overneeded folders and mail.
0
 

Author Comment

by:nti1999
ID: 39833090
These users have the "Manage Send As Permission..." as well as "Manage Full Access Permission..." at the Exchange level; and only a few are experiencing the problem. I am assuming that this is an issue when the size of the .ost file reaches a certain size.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39833149
If you add the account as an Additional ACCOUNT then it gets its own OST file.

If it was throttling then it would affect some users then others, simply because throttling is real time.

Simon.
0
 

Author Comment

by:nti1999
ID: 39833324
Simon,

That's actiually what is happening. It'll only be a few users at first; but over time they'll all need to be addressed.
I haven't seen any event ID with 9646. I've also made an attempt at adding an account separately, which works; but it seems too tedious to do that for more than 10 users. Not sure of how to fix this if it is a throttling issue.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39833341
If it is a throttling issue then you need to create and apply a throttling policy to the shared mailbox.

Run this command to begin with, changing the "Shared Mailbox" bit to something to match the name of the mailbox you are setting it to.

New-ThrottlingPolicy "Shared Mailbox Throttling Policy" -RCAMaxConcurrency:20

Then run this command:

Set-Mailbox Sharedmailbox -ThrottlingPolicy "Shared Mailbox Throttling Policy"

Adjusting the name to match the above.
It will take an hour or so to apply. I would wait at least two hours.

Test again.

If the problem continues then you can try increasing the value

Set-ThrottlingPolicy  "Shared Mailbox Throttling Policy" -RCAMaxConcurrency 40

Again you must wait at least an hour, preferably two before considering the test to have failed or not.

Simon.
0
 

Author Comment

by:nti1999
ID: 39833534
Simon,

I'll try this and update status. Hopefully this will correct this issue.
0
 

Accepted Solution

by:
nti1999 earned 0 total points
ID: 39837212
I've been able to resolve the issue. It was a data file setting in Outlook that needed to be disabled.

I went to the Account Settings in Outlook and clicked the "Data Files" tab. Clicked on "Settings" and then the "Advanced" tab. I then unchecked "Download shared folders" under Cached Exchange Mode and clicked "OK".

After restarting Outlook on these computers I was then able to see all new emails.

Thank you both for your suggestions and I truly appreciate the assistance.
0
 

Author Closing Comment

by:nti1999
ID: 39846832
Upon further research I've found that this solution would suffice for the time being. There may eventually be a Throttling issue as our database grows; but I'm content with this solution as of now.
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video discusses moving either the default database or any database to a new volume.

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question