Mac 10.7 users unable to resolve DNS name


We have a handful of Mac users on a Windows network.  They are all trying to connect to a Windows 2008 file share.  This was working without any issue until the file server was dropped from the network.  We rejoined the file server to the network with the same IP address.  

Now the Mac users can only access this file share the IP address but not the servers resolved name.  

Unfortunately they use a software(Automated Engine) that will only let them access using the server's name so they cannot access any files in that software.  

Any ideas or help would be appreciated.  Please keep in mind I don't know much about the Mac world.

Thank you
Who is Participating?
EdTechyConnect With a Mentor Commented:
Just to be clear.. Hit the return key after typing sudo killall -HUP mDNSResponder. Then enter the password
You can connect to a server via its IP address or DNS name. If it is required or more convenient in your environment, you may also use other valid URL formats, such as:


Have you tried this????
MeowserMAuthor Commented:
Yes we have tried this.

We CAN connect when we use:  cifs://IP.IP.IP.IP/ShareName
but we CANNOT connect when we use:  cifs://ServerName/ShareName
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to and use offer code ‘EXPERTS’ to get 10% off your first purchase.

You could try flushing the dns cache.
You will need to be logged on as a user with admin privileges.
Open Terminal - Utilities>Terminal
type sudo killall -HUP mDNSResponder
enter the users password.
Try to connect.
MeowserMAuthor Commented:
I am going to try that and post results  Thankyou!
Check the Mac's network settings to make sure the DNS server is pointed at the IP address of your DNS server.

Also make sure you have the right workgroup name in the WINS tab of the Macs' network settings.
MeowserMAuthor Commented:
This resolved the issue.  thank you for the clear instructions.  Much appreciated
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.