Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Outlook Anywhere Help

Posted on 2014-02-04
14
Medium Priority
?
352 Views
Last Modified: 2014-02-05
Hi, i have an SBS 2008 server with Exchange 2007 installed. Now i enabled Outlook Anywhere in the Exch Console, and for the external URL (remote.mydomain.com), i purchased an SSL cert and got that installed successfully.

On my machine I am trying to setup an email account and i am getting a "The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action."

I followed these steps for the Outlook 2010 configuration:
http://help.em.ucla.edu/app/answers/detail/a_id/1221

What i am missing?
0
Comment
Question by:Cobra25
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 3
  • +1
14 Comments
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39834809
Do you have Autodiscover records in your DNS?
Depending on the type of certificate purchased it will depend on what records you need.

Simon.
0
 
LVL 3

Expert Comment

by:Krishna Patil
ID: 39834811
Can you post output of "Get-OutlookAnywhere" command?
0
 
LVL 4

Author Comment

by:Cobra25
ID: 39834815
i created an autodiscover cname and pointed to the remote A record. Still waiting for it to propogate.

I purchased just a 1 domain SSL cert from godaddy.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 4

Author Comment

by:Cobra25
ID: 39834827
[PS] C:\Windows\System32>Get-OutlookAnywhere
WARNING: IIS://FS2.miller.local/W3SVC/1/ROOT/Rpc was not found. Please make
sure you have typed it correctly.


ServerName                 : FS2
SSLOffloading              : False
ExternalHostname           : remote.****.com
ClientAuthenticationMethod : Basic
IISAuthenticationMethods   : {Basic}
MetabasePath               : IIS://FS2.miller.local/W3SVC/1/ROOT/Rpc
Path                       :
Server                     : FS2
AdminDisplayName           :
ExchangeVersion            : 0.1 (8.0.535.0)
Name                       : Rpc (Default Web Site)
DistinguishedName          : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=
                             FS2,CN=Servers,CN=Exchange Administrative Group (F
                             YDIBOHF23SPDLT),CN=Administrative Groups,CN=First
                             Organization,CN=Microsoft Exchange,CN=Services,CN=
                             Configuration,DC=miller,DC=local
Identity                   : FS2\Rpc (Default Web Site)
Guid                       : e87fce20-5769-4223-8b4e-0012db9726a0
ObjectCategory             : miller.local/Configuration/Schema/ms-Exch-Rpc-Http
                             -Virtual-Directory
ObjectClass                : {top, msExchVirtualDirectory, msExchRpcHttpVirtual
                             Directory}
WhenChanged                : 2/5/2014 12:21:31 AM
WhenCreated                : 12/22/2010 2:27:40 PM
OriginatingServer          : FS2.miller.local
IsValid                    : True
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 2000 total points
ID: 39834853
A CNAME is not suitable if you have a single name SSL certificate, as it will generate certificate errors. You need to use an SRV record.
http://semb.ee/srv

That will need to point to remote.example.com.
Delete the CNAME.

Was the server setup by the SBS wizards? You shouldn't have done anything in the Exchange console and by default on SBS 2008 Outlook Anywhere is enabled.
I would disable Outlook Anywhere in Exchange 2007 console, wait 15 minutes for that change to be done by Exchange. Then run the fix my network wizard in the SBS console. SBS does things in an odd way and if you try and configure things outside of SBS it breaks quite badly.

Simon.
0
 
LVL 3

Expert Comment

by:Krishna Patil
ID: 39834866
*Instead of creating use profile manually, please try following thing.
--> Login to machine by any user who has mbx on exchange 2007.
---> open outlook, let outlook do auto discovery.
---> If OL gets opened successfully, check the "Connection" setting.


 if this does not work, please reply for following questions

1) Do you have single exchange 2007 server?
2) Does all roles installed on same server?
3) What are SUBJECT ALTERNATE NAMES (SAN) in the certificate , that you got from godaddy?
  Does it include, external, internal,auto discover name of exchange server?
0
 
LVL 4

Author Comment

by:Cobra25
ID: 39834871
Simon - thanks for the tip, i added a SRV record instead of CNAME. Outlook anywhere was on by default.

Manoj- 1 exchange server, all roles on it, no other SAN (it is for 1 domain)
0
 
LVL 3

Expert Comment

by:Krishna Patil
ID: 39834946
Automatic profile creation is failing?
0
 
LVL 4

Author Comment

by:Cobra25
ID: 39834947
i am getting that error message. Nothing happens after.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39834949
Did you run the fix my network wizard in the SBS console? I suspect this is due to a change being made outside of the SBS system and the wrong web site is being used.

Simon.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 39836595
Make sure there is no wildcard (*) CNAME record in your domain's DNS. If there is, remove it.

If you continue to have issues, use https://testconnectivity.microsoft.com/ to resolve them.

Jeff
0
 
LVL 4

Author Comment

by:Cobra25
ID: 39837348
Simon - i disabled and enabled the outlook anywhere and ran the fix my network wizard.

I am still getting the same error though when trying to connect. On a side note, the get-outlookanywhere does not return any warnings as it did before
0
 
LVL 4

Author Comment

by:Cobra25
ID: 39837359
Jeff - i ran the RPC over HTTP test on the test microsoft site, everything was successful.
0
 
LVL 4

Author Comment

by:Cobra25
ID: 39837379
Retested it now, and its working.

Thanks Simon!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article I discuss my selections of the Top Four free Outlook OST File Viewers available. Open, view and read even damaged OST files by using these tools. They all provide a clear preview of all data such as emails, notes, tasks, calendars, e…
By default Outlook 2016 displays only one time zone in the Calendar. The following article explains how to display two time zones in one calendar view.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question