Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Outlook 2010/2007 prompting for authentication with Exchange 2010

Posted on 2014-02-05
6
Medium Priority
?
515 Views
Last Modified: 2014-02-11
So I did the migration of one of our clients from Exchange 2003 to Exchange 2010 and managed to get mailflow and everything working.
One issue that I have not been able to sort out is the Outlook 2010/2007 random authentication prompts.

When opening Outlook, it would sometimes prompt for your username and password (not always) and proceed to open your mail client and able to read your emails.
While working on Outlook, it would prompt for a username and password again, typing in the username and password would make the box disappear, but later return.

Note, this is not for ALL Outlook clients, it's random and no way I can replicate it by doing something. Exchange Proxy is unticked (users are stationary). Checked the connection status, attached are 2 files, 1 before password, 1 after.
Before:
 Before Password
After:
 After Password
0
Comment
Question by:fulloutput
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 18

Expert Comment

by:Sushil Sonawane
ID: 39835285
Please check the under IIS on the Exchange server.  Under Autodiscover properties> Directory Security> Authentication Methods> "Integrated Windows Authentication".  must be selected.


Make sure exchange server update with latest service pack and outlook also. You exchange services also started state.

Your exchange installation folder and database and log path folder exclude in antivirus scan.

If still issue is not resolved then please recreate the following directory in iis.


    Autodiscover
    EWS
    RPC
    OAB


The above mention directory authentication method should be Integrated Windows Authentication"
0
 
LVL 4

Expert Comment

by:pcmghouse
ID: 39835337
Please check if your clients are getting the correct URLS "test e-mail auto configuration".
May be one of the links is pointing to the wrong place.

Do you have any public folders?

Then we can troubleshoot from there.
0
 
LVL 2

Author Comment

by:fulloutput
ID: 39835423
I tried running the test email auto config, but it just seems to hang half way through.
Although, what I did see is, the OWA link differs from the one that we actually use externally to access OWA.

The link on test auto config: exchange.domain.com
The link I use to access owa externally: exchange10.domain.com

Would this cause any issues?

Yes, I needed to migrate all public folders as the client uses it extensively.
0
Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 1500 total points
ID: 39838670
Sounds like you don't have the URLs configured correctly within Exchange.
You need to correct them to match the SSL certificate. Authentication prompts are also a sign of an SSL certificate issue, such as a name mismatch - basically Outlook cannot cope with the SSL prompt.

Go through my guide here:
http://semb.ee/hostnames

You will need to have a SPLIT DNS system in place.

Simon.
0
 
LVL 11

Expert Comment

by:hecgomrec
ID: 39839332
I think the issue here is with credentials authentications.

Try this:

Opene IIS on the Exchange server and check the following directories under the
default website:
             default web site
             oab
             autodiscover

Under the directory security tab of each of them, click Edit in the Secure
Communications section,  under Client Certificates set to Accept for each of the folders.
Stop an restart IIS.

Post your results.
0
 
LVL 2

Author Closing Comment

by:fulloutput
ID: 39850080
Hi Simon,

I followed your advice and the random authentication prompts were resolved :) However, to rub salt in my wounds, a smartcard prompt started with some of the users, completely random.
I managed to get it sorted by changing the ssl settings of the default, oab and autodiscover sites to Require Cert, and Ignore.

Thanks,
HS
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question