[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 199
  • Last Modified:

DNS not configured properly

Experts,

I have recently upgraded my domain controller from server 2003 to server 2008 R2, this server was acting as my primary DNS server and DHCP server. I have successfully moved all the services over to the new server but I am running into an issue where my users cannot get on the internet anymore unless I put 4.2.2.2 in as a secondary DNS server.  Why is that?

Every client PC I have to do the same thing when before the migration it was working without it.

Thanks!
0
CervisTECH
Asked:
CervisTECH
1 Solution
 
Manjunath SulladTechnical ConsultantCommented:
If you change it to your local DNS IP,

Are you able to do nslookup for google.com and other sites,

If that is working fine, Then there is no problem with DNS configuration,

Also check Firewall settings and DNS Forwarder settings,

Please go through below Technet article for info,

http://social.technet.microsoft.com/Forums/windowsserver/en-US/730234ed-36af-491f-be64-ebc3af871235/dns-configuration-works-fine-but-get-no-outbound-internet-access?forum=winserverNIS

http://msmvps.com/blogs/acefekay/archive/2010/10/11/edns0-extension-mechanisms-for-dns.aspx
0
 
tmoore1962Commented:
Check this check list is this how you did it?
http://www.ehow.com/how_5715092_replace-domain-controller-windows.html

On a workstation open command prompt and do an IPCONFIG /ALL are all the parameters correct?  i.e. default gateway DNS servers subnet etc.
0
 
CervisTECHAuthor Commented:
Yes this is how I did it. the parameters are correct.

The primary DNS server is 172.28.32.10 which is the new Domain Controller. But as a fix I was able to go into DHCP services and add the 4.2.2.2 to the DNS Servers option. This seem to work so now I do not have to go to every PC and add it. But it's funny that I would need to do that in the first place.

Thanks!
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
CervisTECHAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for CervisTECH's comment #a39836561

for the following reason:

Went into DHCP services and add the 4.2.2.2 to the DNS Servers option.
0
 
Craig BeckCommented:
That's a bad solution.

You should configure 4.2.2.2 as a forwarder in DNS.  Don't give that as a direct DNS server to domain clients as they'll try to ask for SRV records at 4.2.2.2
0
 
giltjrCommented:
If 172.28.32.10 is your primary DNS server, do you have any forwarders configured on it?  If not, you should.

What you did MIGHT have helped some, but it could cause random problems.

The DNS resolver on windows will send a DNS lookup request to all DNS servers coded almost at the same time.  It will accept the first answer it gets.  So if you are looking up an internal host name and for some reason your internal DNS server is super busy and 4.2.2.2 happens to answer first with a "no such host" that is the answer your computer will accept.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now