• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4353
  • Last Modified:

Security Alert Message Keep Popping Up

I keep getting a security alert massage as shown in the attachment. I am using Microsoft XP Professional. Please advise how to get rid of.
revocation-securityCertificate-0.pptx
0
Big__Al
Asked:
Big__Al
4 Solutions
 
David Johnson, CD, MVPOwnerCommented:
Please don't use powerpoint but enbed the pictures instead
You need to update your root certificates via windows update (optional update)
0
 
regmigrantCommented:
this isn't an error on you pc - just a warning that the certificate path is incomplete, basically explorer is telling you that some of the details of the certificate are missing/unavailable.

you can try reinstalling the certificate after removing any existing copies to see if you local certificate Database has a corruption but it may be that the certificate owner actually has the problem

also confirm that you have all latest root certificates, there are optional updates so may not have been applied
0
 
web_trackerCommented:
When you view the certificate you can click on the button to install certificate, if you trust the issuer of the certificate, in this case it is Geo Trust SSL CA.
0
Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

 
Big__AlAuthor Commented:
I am not sure I can trust the issuer because I am not sure what the certificate is needed for.How can I find out this information?
0
 
web_trackerCommented:
if when you get this popup you trust the website normally be installing the certificate you would be fine. The reason you got this popup is because your security settings in Internet Explorer is set so that if a webpage does not have a security certificate that is already accepted by MS of accepted by the end user of the computer then you will get the popup which will prevent you from visiting that website. You can turn off the security settings in IE if you do not want to continue to accept certificates. By accepting the certificate you are saying that this site is safe to visit.
0
 
web_trackerCommented:
The GeoTrust brand is now owned by Symantec
0

Featured Post

When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot has fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now