Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Grep for specific files and then delete them

Posted on 2014-02-05
14
Medium Priority
?
583 Views
Last Modified: 2014-02-08
Hello,
   I have a directory full of images with two naming conventions:

1234.jpg

- and -

1234_1.jpg

I want to search the directory for all files that DO NOT have the underscore and list them in a text file for me to view and confirm.  Once confirmed I want to delete all the file names on the list generated.

I assume I can grep the directory to get my output and then redirect the output to a delete command some how.

Grateful for any guidance.
0
Comment
Question by:compcreate
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +4
14 Comments
 
LVL 48

Assisted Solution

by:Tintin
Tintin earned 1000 total points
ID: 39837859
ls *.jpg | grep -v _ >/tmp/filelist
cat /tmp/filelist | xargs rm -f
0
 

Author Comment

by:compcreate
ID: 39837877
The first line worked to create the proper list, however the second line did not delete them.
0
 
LVL 6

Expert Comment

by:Shiju Jacob
ID: 39837888
cat /tmp/filelist | xargs -0 rm
0
The Orion Papers

Are you interested in becoming an AWS Certified Solutions Architect?

Discover a new interactive way of training for the exam.

 
LVL 48

Expert Comment

by:Tintin
ID: 39837889
Should have deleted the files if they had no spaces in their name.

If they have any spaces, use

cat /tmp/filelist  | xargs -I{} rm -f "{}"
0
 
LVL 13

Expert Comment

by:Sandy
ID: 39838018
Perfect Tintin

#cat /tmp/filelist  | xargs -I{} rm -rf "{}"

Just to add "r" in-case some folders

TY/SA
0
 

Author Comment

by:compcreate
ID: 39838804
This still did not work.  The file names do not contain spaces.  They are exactly as I first described HOWEVER I did notice something else...

when I ls the directory the files look like this:

1234.jpg*
13456.jpg*
123_1.jpg*

etc....

So I do not know what the * is after the extension but could that be affecting this?

thanks!
0
 
LVL 13

Expert Comment

by:Sandy
ID: 39838813
#ls *.jpg? | grep -v _ >/tmp/filelist

#cat /tmp/filelist  | xargs -I{} rm -rf "{}"

to see with ls as what is the use of these "*" directories/files use #ls -laF

TY/SA
0
 
LVL 84

Expert Comment

by:ozo
ID: 39838831
ls -F
would display * after executable files,
but .jpg files are usually not executable
0
 
LVL 19

Expert Comment

by:xterm
ID: 39839181
The * is just indicating that the files have executable permissions - this is fine, and won't affect the command.

Are you running the second command from the same folder where you ran the first command?  If you cd'd to /tmp to look at the filelist and then ran the 2nd command from there, it would not work.  You need to cd back to where the directory where the files are.

You can better see what is going wrong if you do this:

cat /tmp/filelist  | xargs rm -i

This will prompt you for deletion on every file in the list, and then you can see what it's trying to do, and where it's failing.
0
 
LVL 48

Expert Comment

by:Tintin
ID: 39840686
You have ls aliased, so change

cat /tmp/filelist | xargs rm -f

to

cat /tmp/filelist | xargs /bin/rm -f
0
 

Author Comment

by:compcreate
ID: 39843557
when I run:

cat /tmp/filelist  | xargs rm -i

I get this:

rm: cannot lstat `17428.jpg*': No such file or directory

The first command works perfectly and gives me the list I need.  The second goes through and produces and error for 17428 different pictures that it can't find to delete.

Thanks
0
 
LVL 84

Expert Comment

by:ozo
ID: 39843756
If the list is not too long, a quick and dirty work around might be
rm -i `cat /tmp/filelist`
but that could also delete 17428.jpg.zzz

Another workaround might be
echo *.jpg | grep -o '\<[^_ ]*.jpg\>' >  /tmp/filelist
0
 
LVL 30

Accepted Solution

by:
serialband earned 1000 total points
ID: 39843801
If your ls command is aliased, then precede the command with a backslash to temporarily unalias the -F option it so that you don't display the * after the file name.

This is the same as Tintin's and Sandy's example but with a \ preceding the ls command.

\ls *.jpg | grep -v _ >/tmp/filelist
cat /tmp/filelist  | xargs -I{} rm -rf "{}"
0
 

Author Comment

by:compcreate
ID: 39844217
THAT DID IT!  Thanks!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question