Solved

Installing Kolab 3.1 on a  Ubuntu 13.10

Posted on 2014-02-06
12
1,900 Views
Last Modified: 2014-02-18
hi ,
please advice me how to Installing Kolab 3.1 on a new Ubuntu 13.10 server.
0
Comment
Question by:Karunakar Tiwari
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
12 Comments
 
LVL 35

Expert Comment

by:Dan Craciun
ID: 39838244
OK. What part of the installation guide is not working: http://docs.kolab.org/installation-guide/ubuntu.html ?

HTH,
Dan
0
 

Author Comment

by:Karunakar Tiwari
ID: 39838724
hi,
I am getting error please for details please check the screenshot.
error.png
0
 

Author Comment

by:Karunakar Tiwari
ID: 39840538
Hi,
hardly i manage to install kolab 3.1 on Ubuntu 13.10,after installation when i start setup of Kolab i got error,please check the attached  error
Please advice me what step should i take to get rid from this issue."
error.txt
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 34

Expert Comment

by:Duncan Roe
ID: 39845221
You need to install all the packages mentioned in your  post http:#a39838724
Have you done that?
Assuming you did, then on the Confirm Password prompt you should have typed YZHUyrUrxMn66Xd. (You should also have saved that string for future reference). Did you do that as well?
0
 

Author Comment

by:Karunakar Tiwari
ID: 39845244
hi,
I have Done all setup as you mention is post now when i run setup-kolab command i got error,please find the enclosed error allachment.
error.png
0
 
LVL 40

Expert Comment

by:noci
ID: 39845290
and what is in the files mentioned in the error message?
/var/log/kolab/setup.{error,out}.log?
0
 

Author Comment

by:Karunakar Tiwari
ID: 39845427
hi
below is error in log file ,
[Setup] Info Could not copy file '/etc/dirsrv/config/certmap.conf' to '/etc/dirsrv/slapd-cytracon4/certmap.conf'.  Error: No such file or directory
[14/02/09:16:25:15] - [Setup] Fatal Error: Could not create directory server instance 'cytracon4'.
[14/02/09:16:25:15] - [Setup] Fatal Exiting . . .
Log file is '/tmp/setupFtxJ0Q.log'
0
 
LVL 34

Expert Comment

by:Duncan Roe
ID: 39846655
dirsrv is its default user name. You could try installing again using that instead of root, which it explicitly told you not to do. If dirsrv is not in your /etc/passwd, you could create it thus
# useradd -c dirsrv -d / -r -s /bin/false -U dirsrv

Open in new window

No one can log in as dirsrv so you don't really need a password. You can use passwd dirsrv as root to give it one if you like.
0
 

Author Comment

by:Karunakar Tiwari
ID: 39847349
Hi ,
Tried with above instruction,still i got above error,
please advice.
Could not copy file '/etc/dirsrv/config/certmap.conf' to '/etc/dirsrv/slapd-cytracon4/certmap.conf'.  Error: No such file or directory
Error: Could not create directory server instance 'cytracon4'.
0
 
LVL 34

Expert Comment

by:Duncan Roe
ID: 39848479
Have a look in /etc. Is there a dirsrv directory at all? With what contents, if so? Is there a cetmrap.conf somewhere else? (find /etc -name cetmrap.conf)
If you have followed the install instructions exactly and it has failed, then you have encountered a bug. You should report it to Kolab.org. Ideally you would install on a clean system first (i.e. not a system already containing a failed install as you have now). Can you run up a VM and try that?
0
 
LVL 40

Accepted Solution

by:
noci earned 500 total points
ID: 39849163
the dirsrv directory is created with it's contents during the aptitude install kolab part.
Did you have error messages there?

(error message may be in /var/log/setup.*.log
* = error or out
)
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Help creating a custom privilege level in a Cisco switch or router 3 66
SSH setup on ASA 5505 17 122
Enable SPF on IMSVA 6 66
ifconfig related commands 6 21
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question