Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1373
  • Last Modified:

very slow site

Hi,

I have this site www.spargo.co.il
it is extremely slow (15-20 seconds per page), I enabled Super Catch with no big difference.
I tried to activate another theme - didn't help, same speed.
I have another site on the same server that works good, so it is not a server problem.
any ideas from the experts?

thanks.
0
moshik008
Asked:
moshik008
1 Solution
 
Jason C. LevineNo oneCommented:
There's a lot of different things going on with that site.  The biggest culprit appears to be the revslider plugin but it could also be due to image size and having a ton of javascript loading on the page.

You might want to disable the slider to see if the response improves.  If not, the next thing is to try and load as much javascript as you can in the footer.  See:

https://developers.google.com/speed/pagespeed/insights/?url=http%3A%2F%2Fwww.spargo.co.il%2F

for more information but basically you have a bunch of javascript and CSS files that have to load before the page will render in the browser and that could be causing the delay.  You can minify and combine CSS and javascript any number of ways and that will drastically improve page load times.
0
 
Scott Fell, EE MVEDeveloper & EE ModeratorCommented:
You have a script that is accessing  /wp-admin/-admin-ajax.php and it is showing on my end 6 seconds to load.

<script type='text/javascript'>
/* <![CDATA[ */
var CloudFwOp = {"themeurl":"http:\/\/www.spargo.co.il\/wp-content\/themes\/envision","ajaxUrl":"http:\/\/www.spargo.co.il\/wp-admin\/admin-ajax.php","device":"widescreen","RTL":"","responsive":"1","lang":"en-US","sticky_header":"","sticky_header_offset":"0","uniform_elements":"1","disable_prettyphoto_on_mobile":"1","gallery_overlay_opacity":"0.9"};
/* ]]> */
</script>

Open in new window

and that is returning an error
<strong>W3 Total Cache Error:</strong> some files appear to be missing or out of place. Please re-install plugin or remove <strong>C:\Inetpub\vhosts\spargo.co.il\httpdocs\wp-content\object-cache.php</strong>.{"fragments":{"div.widget_shopping_cart_content":"<div class=\"widget_shopping_cart_content\">\n\n<ul class=\"cart_list product_list_widget \">\n\n\t\n\t\t<li class=\"empty\">No products in the cart.<\/li>\n\n\t\n<\/ul><!-- end product list -->\n\n\n<\/div>"},"cart_hash":""}

Open in new window


Since every little thing helps, you should really validate your code.  When you are using jquery/ajax/js it is looking for html tags as well as probably moving things around/adding/hiding.  When the code is out of whack, this can cause troubles.

Click to validate
One of the errors is
Line 497, Column 39: No p element in scope but a p end tag seen.
<p style="text-align: right;"></ul></p>

You have closed a UL tag inside of an opening and closing P tag.  Remember to close tags in the same order they are opened.
0
 
moshik008Author Commented:
it was the woocommerce admin-ajax.php that made the slow loading times becouse of a missing script close tag. thank you Scott for the direction.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now