keep printed documents in different file location

when i check 'keep printed documents' in the printer settings.  i want it to keep them in a different file location other than. \Windows\System32\spool\PRINTERS.  is this possible?  if so how
rjefAsked:
Who is Participating?
 
JullezConnect With a Mentor Network EngineerCommented:
On your Win7 machine, go to start, type - "Print management", open "Print servers", right click "machine name (local)", choose properties, go to advanced. What do you see under "Spool folder"?
0
 
JullezNetwork EngineerCommented:
If you want to save/spool the jobs to another directory, you have to change
 the following registry value:
 1. "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Print\Printers\<your printer
 name>"
 2. Set, the "SpoolDirectory" value to a new directory location.
 3. Restart the print spooler service
0
 
rjefAuthor Commented:
so that saves the job but it doesn't print.  i need to save the job and print it also. Any ideas on how to do that?
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
JullezNetwork EngineerCommented:
If you select "Keep printer documents", your printer doesn't print anymore?

What do you have selected under "Advanced"?

keep printer documetns setting
0
 
rjefAuthor Commented:
when i do this

If you want to save/spool the jobs to another directory, you have to change
 the following registry value:
 1. "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Print\Printers\<your printer
 name>"
 2. Set, the "SpoolDirectory" value to a new directory location.
 3. Restart the print spooler service

it doesn't print anymore
0
 
JullezNetwork EngineerCommented:
Rjef,

I just changed the setting on my machine, and was able to print and also can see the spooled documents in my test directory.
0
 
rjefAuthor Commented:
is you pc windows 7?  do you have uac high?  I will try again
0
 
JullezNetwork EngineerCommented:
I have win7, UAC is set to " Notify only when programs try to make changes to my computer (do not dim my desktop).

You can try to run regedit with admin rights to be sure - hold shift and right click - will give you the option.
0
 
rjefAuthor Commented:
does it matter if i am printing something out of SAP and it using the saplpd control.  i think it is looking somewhere for the document and it is not there.
0
 
JullezNetwork EngineerCommented:
Can you try to print a test page from the printer first please with the spool directory changed?
0
 
rjefAuthor Commented:
i get an error when i do a test print after setting the spool location.  See attachment
Presentation1.pptx
0
 
JullezNetwork EngineerCommented:
I see.

What are the permissions on that shared folder?

Give NTFS/sharing permissions to "everyone" for testing purposes and try again.
Also try a local folder like C:\test before you change it to network path.
0
 
rjefAuthor Commented:
i guess it was the share.  it seems to be working now.
0
 
rjefAuthor Commented:
thanks
0
 
JullezNetwork EngineerCommented:
Glad you were able to make it work .

Have a nice day!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.