Solved

SBS2008 remote web workplace 404 error

Posted on 2014-02-06
27
1,165 Views
Last Modified: 2014-04-16
I'm trying to get to https://remote.servername.com/Remote/logon.aspx on my Small Business Server 2008. It used to work OK.

I can still get to https://remote.servername.com/owa and read email.

Note: I run Trend Micro Worry Free Antivirus on this server.

Server Error in '/' Application.
--------------------------------------------------------------------------------

The resource cannot be found. 
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /Remote/logon.aspx

Open in new window

0
Comment
Question by:Elixir2
  • 13
  • 8
  • 6
27 Comments
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
Anyone?
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
Was Trend in place when it was working before?  New version of trend?
Any change in hardware (new firewall)?
Have you run the fix my network wizard?
Have you installed and run the Best Practice Advisor?
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
Yes, trend was in place when it was working before. I do need to upgrade.
No changes other then Windows Updates.
Have not run the fix my network wizard (doing it now).
Installed BPA and ran it long ago. I also uninstalled it.
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
I suspect many updates have been made to the BPA since you last installed and ran it.
Can you get to remote web workplace internally?
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
Fix my network wizard sez: No certificate is bound to the IIS website. Secure web traffic is blocked until IIS is bound to a certificate.
...and...
A network component is not configured correctly. Component ID #4
If the Fix My Network wizard shows that component ID #4 is broken, this means that the TSGateway service is not configured to correctly use the SSL certiifcate configured within IIS. Continuing to fix this error within the wizard will configure TSGateway property to use the SSL certificate configured inside of IIS and restart the TSGateway service so it will pick up the correct certificate.

Wizard reports both are fixed.

Still 404 error both internal and external. It appears the Remote folder does not exist?

HTTP Error 404.0 - Not Found

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
Does owa (outlook web access) work?
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
Yes both owa and sharepoint work fine.
In IIS it looks like the port 443 which is bound to remote is also in use by owa. The site is stopped, therefore our 404 error.
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
Yes, that's correct they both use 443 and that's why you have to type /remote or /owa
can you start the site?
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
Error: website cannot be started. another site may be using the same port.
the Remote site is in the SBS Web Applications Home
when i view bindings on SBS Web Applications, it see that it has both 443 and 444 bound to https.
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
for some reason during migration, this sbs2008 server is a little different than others. the \remote site is inside the SBS Web Applications pool (as I stated above) but the \owa and \public sites are in the Default Web Site pool.

Is there a way to put \remote in the Default pool?
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
I can run Remote on port 444 no problem.

However, when I try to delete the binding for 443 from the Remote site, the wizard warns that it will break the binding for 443 for the Default site, too.

I'm worried this will cause more problems. Please advise can I go ahead with this and then just put 443 back on the Default site pool bindings?
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
sorry for the delay...this weekend I'll look at one of my customers 2008 SBS servers and give you a better look

444 is not required in SBS 2008, it was in 2003.
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
I understand, but I'm saying that because of the unique setup with this particular server, I can change to 444 to avoid other issues. Just see my concern above about breaking 443 on the other site pool.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
Just looked at one of my customer sites...owa and remote should both be under SBS Web Applications.

I need to research how we get everything where it should be
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
well shoot, meant to add text...so you can enter IIS click on the sites that under the Default website and change the app pool to SBS Web Applications

You should restart the server after that
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
Comment Utility
The place to start for this is http://fixmyrww.com

Jeff
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
Thanks Jeff, but we found the issue. The site is stopped. Trying to restart the site gives: Error: website cannot be started. another site may be using the same port.
As you can see here, my setup is not normal. My RWW (Remote folder) is inside the SBS Web Applications Pool, instead of the Default Web Site pool?
My funky IISThe Default Website pool is bound to port 443 (and 80, etc).
The stopped SBS Web Applications pool is bound to port 443 and 444, and won't start because of 443 above.
RWW USED TO WORK, and some update or something undid my port bindings. I think I had RWW on 444 only? Not sure how to accomplish this now.

As I posted earlier, when I try to delete the binding for 443 from the Remote site, the wizard warns that it will break the binding for 443 for the Default site pool, too.

I'm worried this will cause more problems. Please advise can I go ahead with this and then just bind 443 back on the Default site pool bindings?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
Comment Utility
Ah, ok...

The Remote site is where it is supposed to be.  The problem is that your Exchange sites got moved to the default site which is NOT where they should be.

On an SBS 2008, the Default Web Site is basically empty.

You'll need to follow the steps outlined in this previously answered question to resolve the problem and get your Exchange Virtual Directories moved to the proper location:
http:Q_26309807.html

Also, don't confuse the terminology... there are "Web Sites" and "Application Pools" -- these are two completely different things in IIS.

Jeff
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
Comment Utility
@Cris Hanna:  Don't forget that SBS 2011's IIS config is completely different than SBS 2008's.  The image you posted is from a 2011 box.
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
Jeff - thank you! That helps a ton. I didn't know which site was in the wrong place. And I felt I was screwing up the terminology there too. If you have another minute to spare on this, could you tell me really what an Application Pool is. I'm pretty sure I know what a Web Site is.

I'll check that link and post back here.

Thanks again!
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
The quote that stands out the most to me in that post you linked to is:
The MS techie was successful eventually, but I am led to believe that he did have a particularly hair-raising time getting there, with one or two moments of panic.

I know this is not what you want to hear, but I don't feel the need to put feet in that fire. For this job, on this client, I'm inclined to go with the bandaid rather than the surgery.

We've got maybe three users that will hit this RWW and I KNOW that if I change the port to something other than 443 and rebind stuff, I can get both sites up and running without doing all that "panic-inducing" work. It was working two weeks ago.

So, back to the bandaid... when I try to delete the binding for 443 from the Remote site, the wizard warns that it will break the binding for 443 for the Default site, too. How hard is it to rebind 443 to the Default after I fix Remote?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
Comment Utility
What wizard?  If you want to change the binding for Remote, just do it in the IIS management console.

Jeff
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
In IIS Manager > Sites > SBS Web Applications > Edit Site Binding (right side pane in IIS) it has this: bindingsWhen I click Remove on port 443, the error that stops me is this:error
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
Comment Utility
Yeah... this is essentially the problem.  Because SSL shouldn't be enabled on your Default Web Site.  Until you fix the issue that the "Sites" are in the wrong place you won't be able to enable SSL on both if you are using the same port.

Jeff
0
 
LVL 1

Author Comment

by:Elixir2
Comment Utility
Waaaaa! <cries> but I don't want to use the same port!!! I just want to know if I remove the binding for 443, and it subsequently breaks 443 on all sites, how do I put 443 back on the Default Web site?
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
Comment Utility
You cannot use the same certificate to bind to different ports.  So you would need to have another certificate as well.

The right thing to do is to fix it properly.

Jeff
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
Remote Desktop Connections allow you to control remote host machines via the magic of the Internet and RDP (Remote Desktop Protocol). For the purposes of this article we will assume you are connecting from your home PC or laptop to a remote offic…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now