Exchange 2010 showing internal domain when sending emails

We are getting a few blocked emails saying we are not resolving properly.

I have gone to mxtoolbox and it says that reverse DNS is all good. However I have sent myself a test email and in the header of the email it is showing the local server name instead of the public domain name I specified in the send connector.

Is there something else I have to do?
LVL 6
CaptainGibletsAsked:
Who is Participating?
 
Simon Butler (Sembee)ConsultantCommented:
I knew it would be the "Domain Must Resolve" for some reason. There is an anti-spam product that causes that, and for some reason it looks too deep in to the headers.

That received from you have posted is purely internal, it is the handover from the Mailbox Database role to the Hub Transport role, and cannot be removed because it is internal.

You need to be sure that the PTR matches the FQDN on the Send Connector completely. I would check using some of the internet tools that the results come back completely consistently.

Simon.
0
 
Simon Butler (Sembee)ConsultantCommented:
The tests at mxtoolbox are not accurate, because they test inbound email and then presume that the same settings apply to outbound as well, which they don't.

To confirm how the internet is actually seeing your server, using the test on this site:
http://cbl.abuseat.org/helocheck.html

Follow the instructions carefully, particularly around the results.

Seeing local domains in the headers is normal, because of the way Exchange moves the email between the various services.

Simon.
0
 
CaptainGibletsAuthor Commented:
coming back as configured correctly but I am still getting the off one of these

mail.opgweb.co.uk rejected your message to the following e-mail addresses:
 
someone@somecompany.co.uk (someone@somecompany.co.uk)

 
mail.opgweb.co.uk gave this error:
Domain must resolve

 
A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.

 
 
Diagnostic information for administrators:
 
Generating server: internalserver.domain..local
 
someperson@somecompany.co.uk
mail.opgweb.co.uk #501 Domain must resolve ##
 
Original message headers:
 
Received: from internalserver.domain.local ([::1]) by
internalserver.domain..local ([::1]) with mapi id 14.03.0174.001; Wed, 5
 Feb 2014 11:05:24 +0000
0
 
CaptainGibletsAuthor Commented:
our send connector is set to go out as mail.domain.com not server.domain.local

the ptr points to mail.domain.com i read somewhere a while back that i might have to create a transport rule changing the headers to show external instead of internal?
0
 
CaptainGibletsAuthor Commented:
any ideas anyone?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.