Solved

Exchange 2013 Cumulative Update 3 broke smtp

Posted on 2014-02-07
13
1,053 Views
Last Modified: 2014-02-25
In an attempt to fix another issue with public folder migration, i attempted to install CU3 for exchange 2013.  it fails at 90% when it is doing the prerequisite test with an error regarding restarting the WRMSVC service.  Everything was working fine yesterday until this update failed and now we are not receiving any mail.  I've rebooted the server several times and no change.  I'm not sure where to even start.  Has anyone else successfully installed CU3?  this is a single CAS and mailbox server.
0
Comment
Question by:Ninja03
  • 6
  • 3
  • 3
  • +1
13 Comments
 
LVL 19

Expert Comment

by:Kash
ID: 39842090
anything reported in the event viewer ?
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39842123
I think the only option you have is to uninstall CU3 and again install CU2 then you have to wait for Exchange 2013 SP1 to be released.
0
 

Author Comment

by:Ninja03
ID: 39842130
I have an IIS error around the time i tried to install the update:
 
The description for Event ID 1007 from source Microsoft-Windows-IIS-IISManager cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

IISWMSVC_STARTUP_UNABLE_TO_READ_CERTIFICATE

Unable to read the certificate with thumbprint '156d0a18852448c1abc728917f65e3131696a513'.  Please make sure the SSL certificate exists and that is correctly configured in the Management Service page.

Process:WMSvc
User=NT AUTHORITY\LOCAL SERVICE

the message resource is present but the message is not found in the string/message table


And I also have an error where the installer for CU3 Failed:  

Process ExSetupUI.exe (PID=23212). ServerComponentState for Component 'Monitoring' set by Requester 'Functional' to 'Inactive'.
0
 

Author Comment

by:Ninja03
ID: 39842168
Ahmed786 -

I would have no problems doing that but I don't see it listed in add programs and features where it can be uninstalled.  The only thing I see is the CU2?
0
 

Author Comment

by:Ninja03
ID: 39842185
on the exchange connectivity test site i'm getting this response when trying to do an inbound mail:

Testing TCP port 25 on host mail.electionadministrators.com to ensure it's listening and open.
       The specified port is either blocked, not listening, or not producing the expected response.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       
The connection was established but a banner was never received.
Elapsed Time: 16644 ms.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39842551
Anything else on the server, that could be using or listening to port 25?
You cannot really uninstall an Exchange rollup and install an older one, the rollups don't work like that. They are the full product.

If you run the CU3 setup again, does it prompt you to continue to update?

Simon.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:Ninja03
ID: 39842603
I've tried to rerun the update several times. It always fails at 90% during the prerequisite check. It won't install. I don't know what else could be listening on 25. Everything was working correctly yesterday. I've checked the settings on our Cisco Asa and the port is open and translating to the correct internal address. I've disabled the windows firewall also.
0
 

Author Comment

by:Ninja03
ID: 39843193
Update:  I have found the reason that the CU3 would not pass the prereq test.  The Web Management Service was not started.  I had to go into IIS manager and assign a certificate to it then restart it as detailed in this TN article:

http://social.technet.microsoft.com/Forums/en-US/7f193833-de94-408b-91ad-266d6811a26b/exchange-2013-cu2-to-cu3-upgrade-error?forum=exchangesvrdeploy

Its running right now and appears to be making progress, in the mean time i've re enabled the send/receive connectors on our old EX 2k7 server and changed our NAT and DNS entries.  After the CU3 hopefully runs successfully I hope to be able to switch everything back and get going again.
0
 
LVL 9

Expert Comment

by:Ahmed786
ID: 39846748
Its good to hear that ur issue has been resolved, may this can help others.
0
 

Author Comment

by:Ninja03
ID: 39847612
I finally got this going after several hours trying to reinstall the CU3 using the powershell.  It appears to me that even though the CU3 originally only failed during the prerequisite check it somehow broke exchange.  From what I could see all the relevant exchange services were still up and running but it basically wasn't listening on port 25 anymore.   It seems crazy that the update would do that but it also seems like most of the things with exchange 2013 don't work as expected.
0
 
LVL 9

Accepted Solution

by:
Ahmed786 earned 500 total points
ID: 39849742
You have to wait till SP1 is expected soon for Exchange 2013 :), because many issues has been found so instead of CU4 they will release SP1 directly which will be packed with app CU's.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39852674
CU4 and Sp1 are the same thing - just a different name being applied.

Simon.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39886885
SP1 was released today.
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
EMC RecoveryPoint journal 1 84
NLB Exhange 2016 3 32
Exchange Online Archive 2 57
What is Happening with my Exchange 2010 Server. 9 36
Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now