exchange 2007 database wont mount

Have a small office with about 6 users.  I was on vacation for a couple weeks and the last good backup was the day i left.  Anyway all of the users have ost files on their pc's which i can export to a pst file and get their data.  But i dont know how after i do that i can delete the existing database and create a new one with the users in it so i can put the email back in and start getting mail flowing again.  Since the existing database wont mount i cant move or delete their mailboxes and i need to get them into a new database and delete the old one.
LVL 1
charles18602Asked:
Who is Participating?
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
Personally I would look at why the database will not mount.
Although if no backup has been done then you could restore the backup and then replay the transaction logs, which should get you back to the position of failure.

Exchange rarely does anything without making a lot of noise about it, so something should be logged.  

Simon.
0
 
Kent DyerIT Security Analyst SeniorCommented:
Anything in the Event Log ?

I think you need to give some more diagnostic detail about what has been tried, troubleshooting, etc.
0
 
charles18602Author Commented:
i ended up running a repair on the database to fix the issue and then created a new database and moved all of the accounts into it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.